[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

File system error (power outage)


sometime last night my power must have gone off and back on again, I
came to my computer today in the morning to find it saying:

/dev/hda3: UNEXPECTED INCONSISTENCY; run fsck manually
             (i.e., without -a or -p options)

fsck failed. Please repair manually and reboot. Please note that the
root file system is currently mounted read only. To remount it

# mount -n -o remount, rw /

CONTROL -D will exit from this shell and reboot the system.

So what am I supposed to do now? I really dont have any critical
information in the computer and I wouldn't mind reinstalling again,
however there are about 5 files that I would like to keep. What exactly
am I supposed to do with "e2fsck"? what command should I run? is it
possible to fix this and not have to reinstall? I ran the command:
"mount -n -o remount, rw /" and then I got this message:

warning: mounting unchecked fs, running e2fsck is recommended.

so then I ran "e2fsck /" and I got this message:

WARNING!!! running e2fsck on a mounted filesystem may cause SEVERE
filesystem damage.
do you want to continue [y/n]: 

So I typed no for now. what should I do at this point? what commands can
I run? I would appreciatte any help you can give me. Thanx!

Reply to: