[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: [Solved] Re: installed new kernel, but lost internal network

Kristian Niemi wrote:
I'm not at all sure about this, but when you copied the config from /boot, did you copy it to .config? .../kernel-source-2.4.22-hs1/.config,

Yes, that is what I did.

that is. Might be that it have to be called that, in order for you to be able to do a `make oldconfig', which I suppose is what you tried to do?

Good it worked out for the best anyway. ;)


h: Krisse

H. S. wrote:


Okay, I know what I was doing wrong, or what was going wrong without my actually doing it :)

I extracted the bz2 kernel source archive in /usr/src and to prepare for a compilation, I copied my config-2.4.18-bf2.4 from /boot to kernel source directory (in my case it was kernel-source-2.4.22-hs1/). I assumed this would give me the same configuration as I had in my previous kernel. It was not so. I had to manually enable ip_forwarding, nat filtering, and all the related features in the menuconfig interface. These features were enabled in my older kernel, so I would guess something has changed between the kernel versions and just copying the old config file is not enough, it has to be hand edited to make sure all the options are set correctly as desired -- cannot avoid spending that half an hour going through that ncurses gui afterall :(

I did that (since everything else was working, I figured it *had* to be the kernel) and my network is working perfectly.

I wonder why nobody could suggest this. Nobody has encountered this before? Or nobody does masquarading with Debain (extremely unlikely I would guess, but possible)? :)

Anyway, I hope this report helps someone else facing this problem,

(Remove all underscores,_if any_, from my email address to get the correct one. Apologies for the inconvenience, but this is to reduce spam.)

Reply to: