[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: ATA Controller

On Wed, 19 Nov 2003 00:10:09 +0000
John Peter <john.peter@netcabo.pt> wrote the words:

> Linux wrote:
> >Greetings all.  I have a second IDE controller card installed in my
> >system and am trying to get it to work under debian.
> >
> >Things that may be relevant:
> >
> >hda - 15g HD
> >hdb - 20g HD
> >hdc - cdrom
> >hdd - cdburner
> >and on the second controller
> >hde - 30g HD
> >
> >hde is reiserfs and is operational under my Mandrake 9.1 install, but
> >not seen by my Woody install.  It is a "fresh" install after all the
> >hardware was in place, not hardware added after the install.
> >
> >Hardware specifics:
> >Promise Technology, Inc.
> >Ultra 100 TX2 ATA/100 Controller
> >
> >The manual says to go to www.promise.com for Linux for "updates on
> >Linux support".  Well, I did so, but no found no love.
> >
> >Also tried to Google, but didn't get any results that I understood or
> >could use.
> >
> >So, any suggestions?  I can't help but think I simply need to use
> >modprobe and install a module or such.  I played around with that
> >idea, but didn't hit upon anything that worked.  Of course, since I'm
> >not sure what I'm looking for, I was guessing.
> >
> Ok, Adrien, here are some ideas :
> First take a look at the relevant portio of my dmesg ( you can do the 
> same by openning a terminal and writting dmesg ).Scroll through it and
> see if you find a similar set of lines as mine ( I use the very same
> card )
> PDC20268: IDE controller at PCI slot 00:09.0
> PCI: Found IRQ 10 for device 00:09.0
> PDC20268: chipset revision 1
> PDC20268: not 100% native mode: will probe irqs later
>     ide2: BM-DMA at 0x9800-0x9807, BIOS settings: hde:pio, hdf:pio
>     ide3: BM-DMA at 0x9808-0x980f, BIOS settings: hdg:pio, hdh:pio
> hda: IBM-DJNA-370910, ATA DISK drive
> blk: queue c0379120, I/O limit 4095Mb (mask 0xffffffff)
> hdc: SONY CD-RW CRX1611, ATAPI CD/DVD-ROM drive
> hdd: CD-ROM 48X/AKU, ATAPI CD/DVD-ROM drive
> hde: IC35L040AVER07-0, ATA DISK drive
> As you see I use a disk in the motherboard controller hda and another
> on the Promise controler - no problem whatsoever.
> You can also use lspci as a command to see info on the pci devices and
> there you will have a line like this :
> 00:09.0 Unknown mass storage controller: Promise Technology, Inc.
> 20268 (rev 01)
> So, now what you have to verify is if your kernel suports this driver
> - pdc20268 .
> At the terminal issue the command uname -a and see wich kernel is in
> use. Mine is like this :
> Linux peterpan #1 Tue Oct 28 12:12:30 WET 2003 i686
> GNU/Linux
> wich means that I am using a 2.4.22 kernel ( the rest of the numbering
> is the date of the build).
> If you have a 2.4.18 or later you are OK .Now you just have to see if 
> you have the kernel sources installed - go to /usr/src/ and see if
> they are there .
> If they are there or not I advice you first to read and put on paper 
> this document :
> http://newbiedoc.sourceforge.net/system/kernel-pkg.html
> You will need it to help you getting everything you need to choose
> what modules and how to recompile the kernel (the one you have or a
> new one).
> After that carefull reading you are now able to go into the kernel -
> cd /usr/src/linux and do a make menuconfig
> Then scroll down until ATA/IDE/MFM/RLL support, then to IDE ATA and 
> ATAPI Block devices and then enable (as a module - you don't need it
> in the kernel because it's not your boot drive) Promise 
> PDC202{68|69|70|71|75|76|77} support .
> Then follow all the instructions to build the kernel .
> After everything is done you just have to put your module in the 
> /etc/modules file ( please check in your /lib/modules/"kernel number"
> to see the exact name of the module - I think it should be pdc202xx
> ).It would be a good idea to issue the commands (under root ) depmod
> -a and update-modules .
> I hope this is not to much at a time for you.
> If you have never compiled a kernel this is a good reason to try it -
> if you follow all the instructions on that document you will succeed .
> If I forgot something, my apologies - someone will correct me, I am
> shure.
> Good luck !
> John

Greetings...  Ok, I have been working on this and making some progress,
me thinks...  but not there yet.

First off, thanks for pointing me to that tutorial on building a kernel
package.  That was great.  I'm going to have to browse around there and
see what else they have. 

So, I am compiling ok, I seem to be getting the module, but still no

Now, can anyone tell me how the sequence of events during booting would
affect all of this?  I would think it's somewhat important.  An
extension of that question is of course, how do you control the sequence
of events when booting the kernel?

Below is part of dmesg from my Mandrake install.  I will point out that
this is happening someplace around 2/3 of the way through dmesg.
PDC20268: IDE controller at PCI slot 01:02.0
PDC20268: chipset revision 2
PDC20268: not 100% native mode: will probe irqs later
PDC20268: ROM enabled at 0xff8e0000
    ide2: BM-DMA at 0xa800-0xa807, BIOS settings: hde:pio, hdf:pio
    ide3: BM-DMA at 0xa808-0xa80f, BIOS settings: hdg:pio, hdh:pio
hda: Maxtor 91536U6, ATA DISK drive
hdb: Maxtor 2B020H1, ATA DISK drive
blk: queue c03cb420, I/O limit 4095Mb (mask 0xffffffff)
blk: queue c03cb55c, I/O limit 4095Mb (mask 0xffffffff)
hde: Maxtor 53073H6, ATA DISK drive

Now, here is the message for the same module from my Debian Install.  In
this case, it is the very last thing in dmesg.
PDC20268: IDE controller at PCI slot 01:02.0
PDC20268: chipset revision 2
PDC20268: not 100% native mode: will probe irqs later
PDC20268: ROM enabled at 0xff8e0000
    ide4: BM-DMA at 0xa800-0xa807, BIOS settings: hdi:pio, hdj:pio
    ide5: BM-DMA at 0xa808-0xa80f, BIOS settings: hdk:pio, hdl:pio

Is my problem simply one of sequence of events?  How do I control these

Also, I can not see the drive with cfdisk.  It would be /dev/hde right? 

BTW, kernel 2.4.18 does not have the needed module, or at least the
kernel package in Woody does not.  I ended up going with 2.4.22 which I
had already from a failed previous attempt to build a kernel.

Thank you again.

   On The Fly Photography
   Version: 3.12
 GAT d-@ s: a C++ UL++ L++(+++) P E- W++ !N o? K- w--- M+ PS+++ 
 PE+++ Y+ PGP t++@ 5+++ X++ R+@ tv-- b++ DI++++ D+ G e+ h+ r y++
 ------END GEEK CODE BLOCK------

Reply to: