[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: install local deb file

> Put it in /storage/debs/.=20
> Just to clarify, I would do something like:
> echo "deb file:/storage/ debs/" >> /etc/apt/sources.list
> dpkg-scanpackages /storages/debs /dev/null | gzip > /storage/debs/Packages.=
> gz
> apt-get update
> apt-get install whatever

Nick, this is one thing I originally tried, but failed. This time, it think
I got a bit further. 

I'm trying to install libdvdcss2 to that I might view DVD on xine. I
found it and put it into my local /storage/debs directory, along with
two dependencies, libc6 and libdb1. I did the Packages.gz creation,
informed storage.list of the location, and did the update. 

So far so good. The Packages.gz holds three packages, but since I want
to install the libdvdcss2 primarily, I installed it, hoping that it
would figure out the dependencies and install them, too. Apparently I
was wrong. I get something like this:

  Reading package lists...
  Building Dependency Tree
  Reading extended state information
Then removal of unused packages (including my Qt3 libraries, which I
installed in preparation for installation of an application that will
need them). Then it said that two of the three packages in Packages.gz
will be intalled, and one package (the libc6) will be upgrades. Except
for at least one group of undesired removals, sounds good.

I'm told how many packages will be removed, installed and upgraded,
and the space required. That sounds right. So I say, Continue, and it
proceeds to write extended state information. But then:

  Err file: debs/ libsdb1-compat 2.1.3-7
    File not found
  Err file: debs/ libc6 2.3.2-9
    File not found

So it was unable to find the two dependencies in the Packages.gz, and
yet also apparently somehow managed to install the libdvdcss2 that
depended on them, which I don't understand. 

I run 
  # apt-cache pkgnames | grep libdvdcss2 

which I take it means the installation of this packages suceeded. But
the command also tells me that libsdb1-compat not installed, and libc6
not upgraded. 

Should I have have run # apt-get install libdvdcss2 libsdb1-compat
libc6=2.3.3-9? I tried, but got the same Err file messages as above
(although no Removals this time, of course).



Reply to: