[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: upgrade->dead system, help.

On Mon, Nov 03, 2003 at 10:12:50AM +0100, wsa wrote:
> Also i'm still wondering what this
> linux-kernel-headers_2.5.999-test7-bk-6_i386.deb
> "linux-kernel-headers - Linux Kernel Headers for development"
> is doing on my system.
> Is this package at all related to the 2.5.x kernels?(since
> i don't run anything 2.5 related)

Current glibc is built against 2.6 kernel headers because that's the
only way 2.6 features like NPTL can be supported, and the kernel header
parts of libc6-dev have been split out into linux-kernel-headers for
ease of maintenance. However, this does *not* mean that you suddenly
have to run a 2.6 kernel.

Ignore this package (but leave it installed) unless you're hacking on


Colin Watson                                  [cjwatson@flatline.org.uk]

Reply to: