[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: upgrade->dead system, help.


Thanks for the tip but I wonder if it is the kernel, this kernel has been
running stable for weeks...why would it suddenly crap out after an
upgrade/install of some new/updated packages.

A bit more on the 2.4.18, as i mentioned that one does go through
the complete boot but it couldn't get to /var.
Well, i forgot that the 2.4.18 i was running didn't have ext3 enabled
so i changed the fstab ext3 entries to ext2 and that 2.4.18 kernel
now boots fine....and my /var is still there...and as far as i can tell
nothing went missing at all.
(no clue as to why toms image didn't want to mount hda9 though)

A previous 2.4.22 kernel doesn't boot either and stopped aswell
right after INIT: version 2.85 booting.
I will try a standard debian kernel later tonight but i expect that one
won't go past init either..


At 06:36 1-11-2003 -0500, kmark+debian@pipeline.com wrote:
get a knoppix cdrom.
boot from it.
chroot to your hd partition and see if you can then download a good
kernel and reinstall it.

> Hi,
> Sorry I have very little info on this...no logs or anything:(
> Running SID, with a custom 2.4.22 kernel, ext3 file system.
> HD was checked with the diagnostic utility from IBM, including
> surface (advanced) check and was fine.
> Did an update via dselect  yesterday and after that the whole
> system has died. When i boot the process stops at
> INIT: version 2.85 booting
> followed by a blinking cursor.
> When i ran the upgrade the thing striking me as very odd was
> under "new packages to install"  'kernel-headers 2.5.x.x.' were
> mentioned.
> Not sure of the exact version anymore but it was 2.5 for sure.
> I think it was 2.5.99.
> I was kinda flabbergasted by that and saw no reason why those
> kernel headers should be installed...since i'm on 2.4.
> So i went back into the dselect selection 'mode' and set that
> kernel package to 'purge' so it wouldn't install.
> This gave me a load of 'xxxx depends on kernel-headers 2.5.x.x. ' like
>   from gcc and so on.
> Struck me as utterly weird aswell cause my system never had anything
> 2.5.xxx kerlnel related stuff on it...anyways...thinking 'dpkg knows best'
> i let
> it have it's way and the package in question was installed.
> After getting the packages during install/configure something went wrong
> aswell but silly me didn't pay too much attention since this happens
> quite a lot with unstable and always gets resolved quickly...and
> never ended in something like i'm having now.
> Can't imagine the cause to be those kernel headers even if it's weird
> they were installed, but one of the 20 orso packages which got
> updated.
> An older 2.4.18 kernel does go thru the entire boot process  but
> with may many errors mostly in the line of 'can't find /var/xxxxxxxxxx'
> After that i tried  toms floppy linux to boot the system.
> mount /dev/hda9 results in just getting the'special device
> not found message'.
> And  hda9 happens to be /var. fdisk shows hda9 as there and
> as ext3 but i think the complete filesystem went out da door on
> that partition.
> e2fsck gives me a  'the superbloack could not be read or does not....'
> etc..etc..etc.
> Any ideas on how to get out of this one?...and why this happened?

Reply to: