[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Initrd trouble

On Mon, Oct 20, 2003 at 08:13:59PM -0400, Jerome R. Acks wrote:
> On Sun, Oct 19, 2003 at 05:39:49PM +0200, Ron Rademaker wrote:
> > modprobe: Can't locate module cramsfs
> > mount: fs type cramfs not supported by kernel
> > I use romfs... So I guess I shouldn't need cramfs, why it tries to load
> > it, no idea.
> > I created the initrd with mkinitrd (the debian package) and I've set
> > modules and root to all
> > I do have the pdc-ultra module (this module is the reason I need an
> > initrd image), and using local loop device to mount the image: it is
> > there!!
> /etc/mkinitrd/mkinitrd.conf is mkinitrd configuration file. "mkcramfs"
> is used to make the initrd.img in debian's mkinitrd package.

On a similar note, I'm trying to get an initrd working to load ft3xx
module in 2.4.22.

I tried:

mkinitrd -o /boot/initrd.img-2.4.22-test /lib/modules/

but when it got to the good bit, it wouldn't mount my root fs.  I do
have the ft3xx line in /etc/mkinitrd/modules.

Any ideas?

I then tried to mount /boot/initrd.debinstall so that I could see what
it contained, and "roll my own".  However I can't mount the fricking

mount -o loop -t cramfs /boot/initrd.debinstall /mnt

It said something about /boot/initrd.debinstall not being a block
device.  What am I doing wrong (apart from owning a disk controller with
no kernel driver)?


Reply to: