[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Mouse no longer working after kernel upgrade

On Fri, 3 Oct 2003 18:10:16 -0500, 
"DePriest, Jason R." <jrdepriest@ftb.com> wrote in message 
<[🔎] 03C99898510C8C47945B932907D99AAA16EF61@E2KMEMMCS1.ftbco.ftn.com>:

> I have a Compaq ProLiant 1600 that was running the stock 3.0r1 kernel
> (2.2.20-idepci).
> I upgraded it via apt-get to 2.4.21-5-686-smp.
> While using 2.2.20-idepci, the mouse worked fine in X (using icewm).
> Since upgrading to 2.4.21-5-686-smp, the mouse no longer works.  I
> have tried two different PS/2 mice and a serial mouse.
> I have ran 'dpkg-reconfigure xserver-xfree86' about 50 times.
> I ran 'modconf' and made sure the PS/2 input device module was loaded.
> There is no error.  As a matter of fact, the mouse ~pointer~ is there
> in the middle of the screen... it just doesn't move.
> If I use the LILO menu to boot back into the old kernel, the mouse
> works again.

..good. Use that to verify gpm works in the console, then have X use 
/dev/gpmdata. The cute thing is you no longer have to restart X on 
re-plugging your rodents.

..with your new kernel and X reading /dev/gpmdata instead of some 
weird /dev/pissedoffaux, the problem reduces to get gpm working.

..you _could_ have gpm fighting X over the mouse, stalling it now.

..med vennlig hilsen = with Kind Regards from Arnt... ;-)
...with a number of polar bear hunters in his ancestry...
  Scenarios always come in sets of three: 
  best case, worst case, and just in case.

Reply to: