[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: e1000 cannot bring up intel pro/1000 MT interface

David Z Maze wrote:
Praveen Kallakuri <prav@cox.net> writes:

i have a dell precision 360 with an Intel® PRO/1000 MT Gigabit6
Ethernet LOM. i learned that e1000 is the driver and got it by
compiling kernel 2.4.22. i inserted aprop entries in
/etc/network/interfaces and in modutils/ and updated

What exactly did you do?

in /etc/network/interfaces, i added 2 lines (initially it had just lo):

auto eth0
iface eth0 inet dhcp

in /etc/modutils/eth, i have 1 line:

alias eth0 e1000

i then ran update-modules and checked that the alias has been added in /etc/modules.conf.

finally, i ran ifup eth0. thats when i get the message above and no IP.

when i try to bring up the interface, this message
appears on the console

e1000: eth0 NIC Link is up 100Mbps full duplex

without any obvious error message. but when i check ifconfig, i get
all the lines in a standard interface display except the line with the
IP address and mask. route is empty

That sounds consistent with the state where you've installed a kernel
driver for a network interface, but not explicitly assigned an IP
address to it.  Seeing the relevant fragment from
/etc/network/interfaces would be helpful, I think.

well its supposed to contact a dhcp server and get the IP. i haven't tried statically setting the IP. i am not sure that will work. the dhcp server is beyond my control. but connecting my laptop (which also runs debian) promptly gave my the IP address. there are 2 LED's near the rear of the machine which promptly glow when i insert the ethernet cord. any ideas???


Reply to: