[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: segfault while loading perl script on irssi.

On Thu, Oct 02, 2003 at 06:05:25PM +0200, flibus wrote:
>        I took a look on bugs.debian.org but i didn't find any bug
>        report about this one. I'm on a testing/unstable debian with a
>        2.4.21 kernel taken from the kernel source pacakges and
>        irssi segfault while i want to load perl scripts.
>        In /etc/apt/source.list i got :
>        deb http://ftp.us.debian.org/debian/ unstable main non-free contrib
>        deb-src http://ftp.us.debian.org/debian/ unstable main non-free
>         I'm not sure of the packages which got a problem 
>         (if one got a problem) and i don't know other people
>         who got the same problem (i didn't really search).
>         So if you got a solution don't hesitate to reply :) 

It's related to the perl 5.8.1 upgrade. Supposedly, 5.8.1 is ABI
compatible with 5.8.0, but it seems that it is not, because software
that has an embedded perl interpreter seems to be segfaulting (mod_perl,
irssi, xchat, etc.). This was discussed a bit on debian-perl, but I
don't know if any bugs were filed. 

In the meantime, you can rebuild irssi, or you can downgrade perl.

Dave Carrigan
Seattle, WA, USA
dave@rudedog.org | http://www.rudedog.org/ | ICQ:161669680

Dave is currently listening to Bob Dylan - I And I (Real Live)

Attachment: signature.asc
Description: Digital signature

Reply to: