[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Realtek RTL 8139C and Linux Kernel 2.4.22.

 I asked help some time ago and got no reply... trying again (sorry if
that unappropriate).
 I have very recently installed the Debian 3.0r1 Linux cd, using
default kernel that comes with it, the 2.2.20idepci.
 I am using adsl, whose modem is connected to my only NIC, a Realtek
8139C (not C+, i see 8139C on the chip), and the realtek 8139C driver
(8139too.o) detected 2 network interfaces (eth0 and eth1), both on the
same IRQ (10).
 When i boot, eth0 is brought up and eth1 stays down.
 When i start pppoeconf, it searches for Access Concentrators on
"both" the nics, and finds it in the eth1 card.
 pppoeconf saves my setup, and when i boot, eth0 is brought up, and
eth1 is also brought up. When ppp tries to use eth1, the box resets
(IRQ conflict?).
 I therefore edited the ppp_on_boot script to bring eth0 down and
bring eth1 up, and now everything related to internet works fine in my
2.2 kernel.
 Problem is, I want to install the 2.4 kernel to support all my other
hardware. I installed the same driver, but now it only detects 1
network interface card (which was expected at first). pppoeconf
detects the concentrator in eth0 (which was also expected) (it does
not detect it when i unplug the cable, so i assume its communicating
with the modem), but i am not getting any reply from my ISP's
authentication server (at nor any DNS servers...
 Does anyone what this is all about?
 I have tried to:
 - download the driver from the realtek site, compile it with the new
kernel, same result
 - recompile the 2.2 kernel (debian package), but no 8139too.c within it
 - recompile the 2.4 8139too.c with the 2.2 kernel includes, does not
 None of these attempts succeded.
 Any help is very appreciated, thanks.
 -- Fred

Reply to: