[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Mozilla and Blackdown Java Plugin

On Sun, 24 Aug 2003 18:10:09 +0200, martin f krafft wrote:

> Short summary:
>   Mozilla            JRE                 Works?
>   ============================================== 1.2.1-2.bunk      
>   j2re1.3             YES 1.2.1-2.bunk       j2re1.4             unknown
>   1.3-5              j2re1.3             NO 1.3-5              j2re1.4  
>             NO 1.4-2              j2re1.3             NO 1.4-2          
>      j2re1.4             NO
> Why? And how to fix?
> I am trying hard to get Java to work with Mozilla:
> ii  mozilla-browse 1.4-2          Mozilla Web Browser - core and browser
> ii  j2re1.4 Blackdown Java(TM) 2 Runtime
> Environment, St ii  j2sdk1.4 Blackdown Java(TM) 2
> SDK, Standard Edition
> Java works, Mozilla works, but the plugin does not. j2re1.4 installs
> /usr/lib/j2se/1.3/jre/plugin/i386/mozilla/javaplugin_oji.so via symlinks
> into /usr/lib/mozilla/plugins. If I start Mozilla, then about:plugins
> does *not* list the plugin.
> If I manually link
> /usr/lib/j2se/1.3/jre/plugin/i386/mozilla/javaplugin.so into the plugins
> tree, then about:plugins lists a number of MIME types for which
> Blackdown is responsible, but it's missing one of the important ones:
> application/x-java-vm.
> I tried using j2{re,sdk}1.3 in place of the unstable 1.4 version, but no
> different behaviour. Mozilla 1.3-5 exhibits the same problem.
> I have another machine running older software, and it works flawlessly
> there:
> ii  mozilla-browse 1.2.1-2.bunk   Mozilla Web Browser - core and browser
> ii  j2re1.3    Blackdown Java(TM) 2 Runtime
> Environment, St ii  j2sdk1.3    Blackdown Java(TM) 2
> SDK, Standard Edition
> What's the deal here? Has anyone gotten the Blackdown Java Plugin to
> work with Mozilla 1.4?

I was at one point able to get Mozilla 1.3 to work with Java 1.4 (I since
downgraded mozilla because I wanted to stick with Galeon 1.2 series for

The problem is that Mozilla 1.3 in Debian was recompiled using g++-3.2
which has a different ABI from GCC 2.95 and 3.0. As a result the Mozilla
is now binary-incompatible with the new plugin.

Here's the solution: Blackdown's Java .debs are still compiled with GCC
2.95.x, *but* blackdown does have a binary installer available of Java 1.4
compiled with g++-3.2 which you can use with Mozilla 1.3. You can also use
it to make your own .debs of Java, as I have (but I unfortunately cannot
share them because of bandwidth constraints)

I haven't tried Mozilla 1.4, so I don't know if the g++ ABI is the only
hurdle that you'll have to deal with.

I guess the question is: when will Blackdown make .debs with g++-3.2?

This problem affected Mandrake 6 to 9 months before it affected debian
because Mandrake included g++-3.1 (the first to use the new ABI) whereas
Debian did not.

I usually have a GPG digital signature included as an attachment.
See http://www.gnupg.org/ for info about these digital signatures.
My key was last signed 6/10/2003. If you use GPG, *please* see me about 
signing the key. ***** My computer can't give you viruses by email. ***

Reply to: