[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Mouse Problems

On Sat, 23 Aug 2003 00:20:14 +0200, William Bradley wrote:

> I have just installed Debian (the latest, I forget the number) and got
> it going graphically with Window Maker. Can't get the mouse to work
> though. It is installed on /dev/psaux

That means you have a PS/2 mouse?

> and the pointer is on the screen but immobile. This particular machine
> is dualed with Windows 98, so I looked up the mouse and though it is a
> Logitech mouse, Windows lists it as a PS/2 mouse.


> When I ran "dmesg" it showed the Com 1 was listed as tty00 and I tried
> it at that setting and got the same result.

Let's forget about COM1 for the moment and assume it's a PS/2 model. (You
can find that out easily BTW. Just look at the mouse plug. When it's
round like a circle, it's PS/2.)

So, the usual "my mouse doesn't work" questions:

* What mouse protocol did you set up in /etc/X11/XF86Config-4?

* Do you run the program "gpm"? (If you don't know what that is, the answer
is probably no.)

* Exit from X. At the console, type

	cat /dev/psaux

The program should wait and say nothing. Now move the mouse. Do you get
random garbage on the screen?

Best Regards,   |   Hi! I'm a .signature virus. Copy me into
 Sebastian      |   your ~/.signature to help me spread!

Reply to: