[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Strange error on burning cdrom



Hello,

suddenly, I can't burn CDs without a strange error message anymore. 
I have no idea why, so I hope you can help me, because I don't like
error messages without reason.

Now the details:

Shortly before something went wrong I burned the first pile of CDs for
my thesis with this command perfectly fine (i.e. without error Message):

markus@Eddie: > cdrecord speed=4 diplomarbeit-01.img 

If I do it now, this is the result (I added the -v because I hoped to
get more relevant information, but the error message at the end is
exactly the same without -v). I marked the offending place with " | ":

-----------------------------------------------------------------------
----

markus@Eddie: > cdrecord speed=4 -v diplomarbeit-01.img 
Cdrecord 2.01a10 (i686-pc-linux-gnu) Copyright (C) 1995-2003 Jörg
Schilling TOC Type: 1 = CD-ROM
scsidev: '4,0'
scsibus: 0 target: 4 lun: 0
Linux sg driver version: 3.1.22
Using libscg version 'schily-0.7'
atapi: 0
Device type    : Removable CD-ROM
Version        : 2
Response Format: 2
Capabilities   : SYNC LINKED 
Vendor_info    : 'PLEXTOR '
Identifikation : 'CD-R   PX-W1210S'
Revision       : '1.02'
Device seems to be: Generic mmc CD-RW.
Using generic SCSI-3/mmc CD-R driver (mmc_cdr).
Driver flags   : MMC SWABAUDIO BURNFREE 
Supported modes: TAO PACKET SAO SAO/R96P SAO/R96R RAW/R16 RAW/R96P
RAW/R96R Drive buf size : 2394336 = 2338 KB
FIFO size      : 4194304 = 4096 KB
Track 01: data     2 MB        
Total size:        2 MB (00:17.09) = 1282 sectors
Lout start:        3 MB (00:19/07) = 1282 sectors
Current Secsize: 2048
ATIP info from disk:
  Indicated writing power: 6
  Is not unrestricted
  Is not erasable
  Disk sub type: Medium Type C, low Beta category (C-) (6)
  ATIP start of lead in:  -11231 (97:32/19)
  ATIP start of lead out: 335100 (74:30/00)
Disk type:    Short strategy type (Phthalocyanine or similar)
Manuf. index: 27
Manufacturer: Prodisc Technology Inc.
Blocks total: 335100 Blocks current: 335100 Blocks remaining: 333818
RBlocks total: 343921 RBlocks current: 343921 RBlocks remaining: 342639
Starting to write CD/DVD at speed 4 in real TAO mode for single session.
Last chance to quit, starting real write    0 seconds. Operation starts.
Waiting for reader process to fill input buffer ... input buffer ready.
BURN-Free is ON.
Turning BURN-Free off
Performing OPC...
Starting new track at sector: 0
Track 01:    2 of    2 MB written (fifo 100%) [buf  97%]   5.2x.
Track 01: Total bytes read/written: 2621440/2621440 (1280 sectors).
Writing  time:   10.420s
Average write speed   2.6x.
Fixating...
Fixating time:   61.237s
 | cdrecord: Input/output error. plextor get speedlist: scsi sendcmd: no
error | CDB:  EB 00 00 00 00 00 00 00 00 0A 00 00
 | status: 0x2 (CHECK CONDITION)
 | Sense Bytes: 70 00 05 00 00 00 00 0A 00 00 00 00 20 00 00 00
 | Sense Key: 0x5 Illegal Request, Segment 0
 | Sense Code: 0x20 Qual 0x00 (invalid command operation code) Fru 0x0
 | Sense flags: Blk 0 (not valid) 
resid: 10
cmd finished after 0.001s timeout 40s
cdrecord: fifo had 42 puts and 42 gets.
cdrecord: fifo was 0 times empty and 0 times full, min fill was 100%.

-----------------------------------------------------------------------
----

I _can_ read data from the cd without problem. But I don't like the
line

cdrecord: Input/output error. plextor get speedlist: scsi sendcmd: no
error

I didn't have this "error" earlier and strangely enough, I don't have
this error if I copy CDs on the fly with cdrdao:

cdrdao copy --speed 10  --on-the-fly

Works perfectly fine, while I get exactly the same error if I burn a
cd image with cdrdao...

I have another cd writer in my system. If I do the same with the other
writer, I get exactly the same error, too...

Further information about my system:

Linux Kernel 2.4.18
cat /etc/debian_version 
testing/unstable

My scsi host adapter:
scsi0 : Adaptec AIC7XXX EISA/VLB/PCI SCSI HBA DRIVER, Rev 6.2.4
        <Adaptec 29160 Ultra160 SCSI adapter>
        aic7892: Ultra160 Wide Channel A, SCSI Id=7, 32/253 SCBs

The cd writer I used with the example above:
  Vendor: PLEXTOR   Model: CD-R   PX-W1210S  Rev: 1.02
  Type:   CD-ROM                             ANSI SCSI revision: 02
(scsi0:A:4): 20.000MB/s transfers (20.000MHz, offset 16)

The "other" writer:
  Vendor: PLEXTOR   Model: CD-R   PX-W8220T  Rev: 1.01
  Type:   CD-ROM                             ANSI SCSI revision: 02
(scsi0:A:6): 10.000MB/s transfers (10.000MHz, offset 8)

I really hope you can help me.

Many thanks in advance,

-- 
Markus Grunwald

Registered Linux User Nr 101577
http://counter.li.org



Reply to: