[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: testing -- kdebase-audiolibs dependency

On Fri, 06 Jun 2003 12:34:28 -0600 Harshwardhan Nagaonkar wrote:
> Hello all,
>    I have been trying to upgrade a testing system for about 2 weeks now. 
> I have noticed that there is this following issue:
> #apt-get upgrade
> Reading Package Lists... Done
> Building Dependency Tree... Done
> Calculating Upgrade... Failed
> Sorry, but the following packages have unmet dependencies:
>    kde: Depends: kdebase-audiolibs but it is not going to be installed or
>                  kdebase3-audiolibs but it is not installable
> E: Error, pkgProblemResolver::Resolve generated breaks, this may be 
> caused by held packages.
> If I try to fix this manually with:
> #apt-get install kdebase3-audiolibs
> E: Package kdebase3-audiolibs has no installation candidate
> So then I tried this:
> #apt-get install kdebase-audiolibs
> Sorry, kdebase-audiolibs is already the newest version.

Happened to me also, see bug #194224 ( http://bugs.debian.org/194224 )

The problem went away when I uninstalled kdebase-audiolibs. You'll lose
packages kde (virtual, no harm done) and kdebase-dev (development, not
needed for kde usage).

Also, upgrading to kde 3.1.2 in unstable will take care of it, but that's
a whole new ballgame...


Carlos Sousa

Reply to: