[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: More dist-upgrade problems on stable

On 2 Jun 2003 stan <stanb@panix.com> wrote:

> root@phsepi1:~# apt-get dist-upgrade
> Reading Package Lists... 0%Reading Package Lists... 100%Reading Package Lists... Done
> Building Dependency Tree... 0%Building Dependency Tree... 0%Building Dependency Tree... 50%Building Dependency Tree... 50%Building Dependency Tree... 76%Building Dependency Tree... Done
> Calculating Upgrade... Failed
> Sorry, but the following packages have unmet dependencies:
>   kde: Depends: kdebase-audiolibs but it is not going to be installed or
>                 kdebase3-audiolibs but it is not installable
> E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

> What can I do to fix this?

What I have done when I got messages like this was: trying an install of
the packages that were reported to not going to be installed or to be
not installable. Not in the expectation that they might nevertheless
be installed, but to see what error messages that would generate.
Generally, these say something about the cause of the 'uninstallibility'.
If that cause was that the uninstallable packages depend on one or more
other packages that were uninstallable, I repeated the procedure for those
other packages. Up to now, I always pretty soon found some 'root cause' of
the problem that could be solved by installing / upgrading / removing
packages in the right sequence.

But I admit I never had to do this during a dist-upgrade .... The chain
of dependencies you will encounter when trying this method may be
very long. Just try if no one offers you a better solution.



B.F.M. Kal
Anjelierstraat 1,   2014 TC Haarlem,  Netherlands
tel +31 23 5324909, benkal@euronet.nl

Reply to: