[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Pctel modem problem

Hi Kevin,
thanks a lot for help. i didn't have wvdial so I installed it. But configuration wasn't successful. modem wasn't found. I am not sure which log I should send. there though one discrepancy I found. dmesg, messages and lspci tell me that /dev/ttyS15 has IRQ 9, but setserial says IRQ 2 for both /dev/modem and /dev/ttys15. Somewhere I've read that IRQ 2 and 9 are in fact indentical. i have tried to
setserial /dev/ttyS15 irq 9
but it didn't change anything.

Which log should I send? (wvdial and kppp say only "modem not responding" and minicom and kppp terminal freeze)
Why kppp says "Modem ready" and than shows no Modem query results?
How do I set different IRQ? setserial doesn't seem to change anything.

Kevin Mark wrote:

Hi Petr,
for testing I use wvdial. Also, what setting are use using.
can you provide a log of the errors?
si this the latest package?

On Thu, 2003-05-22 at 12:34, Petr Šimon wrote:
i am sorry, may be this is for a different list, but I've always received the best help from you guys, so I dare to ask here. I am trying to convince a modem on older Mitac notebook to let on internet. So far it only freezes minicom, in kppp I can "query modem", it says "modem ready", but I get no information from those ATI, only blank spaces in all lines. When try to connect to my ISP it says "the modem is not responding". I use pctel-0.9.4 driver which compiles flawlessly. My modem's PCTel PCT789T chipset.
This all  the information I've been working with:

part of my dmesg output:
PCTel device[00:0a.0](0x50) found "PCTel Inc HSP MicroModem 56 (rev 01)", iobase=0x3100, irq=9. PCTel driver version 0.9.5 [5.05c-4.27.215 (09-14-2001)] (PCT789) (2002-01-31) with MANY_PORTS SHARE_IRQ SERIAL_PCI enabled. PCTel driver built on [Linux i686 unknown " <132116>"] with gcc-gcc (GCC) 3.2.3 20030415 (Debian prerelease).
ttyS15 at 0x3100 (irq = 9) is a PCTel
cs: cb_free(bus 2)
PCTel initialization. Country code is 0.
PCTel initialization. Country code is 0.
PCTel initialization. Country code is 0.
cs: cb_alloc(bus 2): vendor 0x1186, device 0x1340
PCI: Enabling device 02:00.0 (0000 -> 0003)
PCI: Setting latency timer of device 02:00.0 to 64

setserial -g /dev/ttyS*:
/dev/ttyS0, UART: 16550A, Port: 0x03f8, IRQ: 2
/dev/ttyS1, UART: 16550A, Port: 0x02f8, IRQ: 3
/dev/ttyS15, UART: undefined, Port: 0x3100, IRQ: 2
/dev/ttyS2, UART: unknown, Port: 0x03e8, IRQ: 4
/dev/ttyS3, UART: unknown, Port: 0x02e8, IRQ: 3

lspci -v:
00:0a.0 Communication controller: PCTel Inc HSP MicroModem 56 (rev 01)
       Subsystem: PCTel Inc: Unknown device 0001
       Flags: stepping, medium devsel, IRQ 9
       I/O ports at 3100 [size=64]
       Capabilities: <available only to root>

cat /proc/ioports:
0000-001f : dma1
0020-003f : pic1
0040-005f : timer
0060-006f : keyboard
0080-008f : dma page reg
00a0-00bf : pic2
00c0-00df : dma2
00f0-00ff : fpu
0170-0177 : ide1
01f0-01f7 : ide0
02f8-02ff : serial(set)
0376-0376 : ide1
03c0-03df : vga+
03f6-03f6 : ide0
03f8-03ff : serial(set)
0cf8-0cff : PCI conf1
1000-103f : Intel Corp. 82371AB/EB/MB PIIX4 ACPI
1040-105f : Intel Corp. 82371AB/EB/MB PIIX4 USB
 1040-105f : usb-uhci
1100-110f : Intel Corp. 82371AB/EB/MB PIIX4 IDE
 1100-1107 : ide0
 1108-110f : ide1
1400-141f : Intel Corp. 82371AB/EB/MB PIIX4 ACPI
3100-313f : PCTel Inc HSP MicroModem 56
4000-40ff : PCI CardBus #02
 4000-40ff : PCI device 1186:1340
   4000-40ff : 8139too
4400-44ff : PCI CardBus #02

cat /proc/pci:
Communication controller: PCTel Inc HSP MicroModem 56 (rev 1).
     IRQ 9.
     I/O at 0x3100 [0x313f].
 Bus  1, device   0, function  0:

I am really at the end of my wits. I've been using Linux for 6 months only (Debian 2 months) and there is still much for me to learn. Can anyone help me with this? Some pointer would be just fine.
Thanks a lot, it would save me from buying pcmcia modem.

Reply to: