[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

dselect can't update

On update, I'm getting the following error:

    Get:1 http://mirrors.kernel.org sarge/main Packages [2257kB]
    Get:2 http://mirrors.kernel.org sarge/main Release [81B]
    Get:3 http://mirrors.kernel.org sarge/contrib Packages [63.8kB]
    Get:4 http://mirrors.kernel.org sarge/contrib Release [84B]
    Get:5 http://mirrors.kernel.org sarge/non-free Packages [63.1kB]
    Get:6 http://mirrors.kernel.org sarge/non-free Release [85B]
    Fetched 2384kB in 15s (150kB/s)
    Reading Package Lists... Done
    Merging Available information
    E: Internal Error, Unable to parse a package record

Note that I've trimmed sources.list to reduce the variables (and
output). I'm running sarge with a few packages from sid. I have apt
0.5.5, dpkg 1.10.10, and dselect 1.10.10. apt itself seems to be happy
(since it doesn't merge the available packages). Any thoughts? Any way
to produce more debugging information?

I tried dpkg --clear-avail and noticed that the action above failed to
create /var/lib/dpkg/available. However, if I ran dpkg --merge-avail on
the Packages files in /var/lib/apt/lists, the available file was created

Today I used dpkg --set-selections to add a few packages which may or
may not be related. Could this have gummed up the works if I had a typo
in one of the packages? How can I clear a package added with
--set-selections by mistake?

I also upgraded for the first time in a week.

Bill Wohler <wohler@newt.com>  http://www.newt.com/wohler/  GnuPG ID:610BD9AD
Maintainer of comp.mail.mh FAQ and MH-E. Vote Libertarian!
If you're passed on the right, you're in the wrong lane.

Reply to: