[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

RE: nvidia-kernel module problem with kernel-source-2.4.18

>> Hi Debian-users,
>> I run woody and try to install the nvidia driver for my NVidia TNT2
>> I have read through many posts and following the advices installed
>> kernel-source 2.4.18 - but when trying to compile the nvidia kernel-
>module it
>> says that I am using a 2.4.18-bf2.4 kernel so there is a mismatch.
>> It is true, my kernel is the *-bf2.4 one (recommended during
>> woody-installation).
>> It is beyond my knowledge what that -bf2.4 means...
>> I looked up my distro but couldn't find anything like a kernel-source
>> 2.4.18-bf2.4, only the simple 2.4.18 one.
>The boot floppy using the 2.4 kernel.
>However, go here, and get the autoinstaller program.  It's very

I recently ran into similar problems with Linux Display Driver Version
1.0-4363 for Linux IA32 released April 24, 2003.  I found that the
autoinstaller program didn't locate a compiled kernel version matching
2.4.18-bf2.4, and then it failed to compile one, complaining about not
finding the kernel header files.  To be brief I'll just tell you what
- installed kernel-headers-2.4.18-bf2.4.  I was surprised that package
search on the Debian web site didn't turn up this package name.  I think
it shows up as kernel-headers-2.4.18-5, but it would have been very
helpful had availability of kernel-headers-2.4.18-bf2.4 been obvious
from the Debian package search.  I suspect 2.4.18-5 and 2.4.18-bf2.4 are
synonymous and if I had been more familiar with kernel distribution
conventions I would have known that. The package installed the headers
at /usr/src/kernel-headers-2.4.18-bf2.4.
- gave the include path to the nvidia installer (kernel headers didn't
go into a location that was searched by default).  Run 'sh *.run
--advanced options' to get the exact syntax for putting in the kernel
headers path.
- I make a tarball to backup of my /lib/modules directory prior to
running the installer.
- The install compiled me a driver fine under the gcc 2.95.4 rather than
the 2.91.66 that, as I recall was recommended in the nvidia
documentation.  I also had installed kernel-package, but never used it
to compile a kernel.
- I ran 'dpkg-reconfigure xserver-xfree86', to select the nvidia driver
rather than nv.
- Upon rebooting the system, X failed to start, giving a message that
the video kernel module failed to initialize.
- Doing 'modprobe nvidia' added it temporarily so that X could then
start successfully.  Autoloading of the nvidia module when X starts
apparently failed for me.
- Adding 'nvidia' to /etc/modules made this permanent.

3D graphics are certainly much faster now!


Reply to: