[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Problem booting software RAID (woody)


I have a minimal woody system up and running and am now trying to convert it 
to software raid1.  Here is the current partitioning scheme:

    /dev/md0 ext3     on /
    /dev/md1 ext3     on /usr
    /dev/md2 reiserfs on /tmp
    /dev/md4 reiserfs on /home
    /dev/md5 reiserfs on /var
    /dev/md3 swap

The raid arrays are all raid1, made up of identical partitions from /dev/hda 
and /dev/hdb.  The drives are both 80G Seagate Barracude ATA-IV.  What I have 

- installed minimal woody system and applied security updates
- changed all partitions to type fd (raid autodetect)
- install raidtools2 and kernel-image-2.4.20-1-686 (from proposed-updates)
- created a /etc/raidtab
- /dev/hdb[1-6] devices are listed first as "raid-disk 0"
- /dev/hda[1-6] devices are listed second as "failed-disk 1"
- formatted the 6 required raid devices
- copied (properly) all data over to raid devices
- chroot into /dev/md0
- modify /etc/fstab in chroot as appropriate
- modified boot and root options in /etc/lilo.conf (within chroot) to
  boot=/dev/md0 and root=/dev/md0
- ran lilo

Since the above did not work I also tried just installing lilo in the mbr 
(boot=/dev/hda, root=/dev/md0) but without success.  I have done similar 
conversions in the past with redhat systems (from 6.2 onwards) without any 

When I run lilo I get the following:

    Warning: Int 0x13 function 8 and function 0x48 return different
    head/sector geometries for BIOS drive 0x80
    Warning: Int 0x13 function 8 and function 0x48 return different
    head/sector geometries for BIOS drive 0x81
    Warning: using BIOS device code 0x81 for RAID boot blocks
    Warning: /dev/md0 is not on the first disk
    Added Linux *
    Added LinuxOLD
    The boot record of  /dev/md0  has been updated.

I have tried playing with the raid-extra-boot option and also the install-mbr 
utility both without success.

Whenever I manage to get lilo actually booting with a raid config the kernel 
panics with a message like "cannot mount /dev2/root".

I have read the raid howtos at tldp.org, checked the Debian FAQ and skimmed 
through the isntallation manual but I still haven't found the magic bullet to 
get this working.  Does anyone know of a Debian specific howto?  What might I 
be missing?  Must the raid support be compiled into the kernel statically ... 
I don't think so since my initrd does include it?

Thanks for any help.
Fraser Campbell <fraser@wehave.net>                 http://www.wehave.net/
Brampton, Ontario, Canada                                 Debian GNU/Linux

Reply to: