[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Terminal Setting Problems ?

Dear all,

Please reply me directly, as at this time, I'm not subscribed to the list.

I'm planning to do telnet connection to this Sun server that provide a program to accessing telecommunication switch and send commands thru it.

The problem is, whenever I tried to connect from X-Window, though I can telnet to the Sun just fine, I always have this strange "Error Occurred during Password/authentication handling..."

But when I try to connect from Virtual Consoles (tty1 - tty6) it's alright. I can manage to connect till finished.

I suspect it has a thing to do with Terminal type or settings as $TERM in VC's show linux while $TERM in gnome-terminal, xterm, or rxvt shows xterm or rxvt terminal.

I tried to change the setting in .bashrc or by using rxvt -tn TERMINAL_TYPE command. But it didn't work. I've also try to change settings in gnome-terminal, such as swap del/backspace, del genereta ^H, and others. But still doesn't work, I kept getting the same error.

What happened here?
Can anybody give me clues?

Best Regards,

ps: While I'm at it, how do you make client server programs from linux to sun when you don't have compiler in the sun machines? I tried to use expect for telnet automation, but still feels that something is not right...

Reply to: