[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: 2.4.20 kernel and RTL8139

Hi Alex

Are you using dhclient? And have you checked /etc/dhclient.conf. All it needs here is hostname and seems to work fine - I am running 2.4.18. It may sound silly but it is also worth checking your ethernet cable setup - I spent 5 night's wrestling with a similar problem to find that I'd wired the cable incorrectly d'oh! ;-)

If dhclient doesn't work you could try pump.



On Tuesday, April 15, 2003, at 12:12  pm, Alexander Borghgraef wrote:

 I'm having a problem getting my on-board NIC to work with the 2.4.20
kernel. I was using Debian with the old 2.2 kernel, under which the
network card worked fine. Then I upgraded to the 2.4.20 kernel, and
suddenly I'm unable to connect to the dhcp server. Using lilo to boot
the old kernel still works fine.
 Before you ask, yes I did include the 8139 card in menuconfig. When
I run ifconfig, eth0 appears in the list alongside lo (loopback device), but it doesn't get an IP address like it did in 2.2. Pinging the network
card ( works, but that's lo I guess? Has anyone had similar
problems, and if so, how do you solve them?

Alex Borghgraef

Clive Menzies & Associates Limited
strategies for business
75 Priory Road, London N8 8LR
d/l: 020 8348 0996
fax: 087 0705 2066

Reply to: