[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: 2.4.20 kernel and RTL8139



Alexander Borghgraef, Tue, Apr 15, 2003 at 02:12:37PM +0200: 
>  I'm having a problem getting my on-board NIC to work with the 2.4.20
> kernel. I was using Debian with the old 2.2 kernel, under which the
> network card worked fine. Then I upgraded to the 2.4.20 kernel, and
> suddenly I'm unable to connect to the dhcp server. Using lilo to boot
> the old kernel still works fine.
>  Before you ask, yes I did include the 8139 card in menuconfig. When
> I run ifconfig, eth0 appears in the list alongside lo (loopback device),
> but it doesn't get an IP address like it did in 2.2. Pinging the network
> card (127.0.0.1) works, but that's lo I guess? Has anyone had similar
> problems, and if so, how do you solve them?
> 

I had the same problem at one point.  IIRC there are two possible drivers
for the 8139 chip: 8139cp and 8139too.  At the time I was testing some
microtel machines from Walmart.  I could not get the NIC to work with
several different kernels.  My solution was to return the machines and
vow to never touch an 8139 NIC again.

g


Attachment: pgpxgcT5twWRQ.pgp
Description: PGP signature


Reply to: