[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

gcc from unstable crashes on Hello World


I did something potentially stupid this weekend and upgraded to "unstable". I wanted to use KDE3 and gcc-3.2. Everything went well and seemed to work.

But when I tried gcc it crashed even on a Hello World application:
"collect2: ld terminated with signal 11 [Segmentation fault]"

jonas@akka:/usr/local/src/mozilla$ gcc --verbose hello.c
Reading specs from /usr/lib/gcc-lib/i386-linux/3.2.3/specs
Configured with: ../src/configure -v --enable-languages=c,c++,java,f77,proto,pascal,objc,ada --prefix=/usr --mandir=/usr/share/man --infodir=/usr/share/info --with-gxx-include-dir=/usr/include/c++/3.2 --enable-shared --with-system-zlib --enable-nls --without-included-gettext --enable-__cxa_atexit --enable-clocale=gnu --enable-java-gc=boehm --enable-objc-gc i386-linux
Thread model: posix
gcc version 3.2.3 20030407 (Debian prerelease)
/usr/lib/gcc-lib/i386-linux/3.2.3/cc1 -lang-c -v -D__GNUC__=3 -D__GNUC_MINOR__=2 -D__GNUC_PATCHLEVEL__=3 -D__GXX_ABI_VERSION=102 -D__ELF__ -Dunix -D__gnu_linux__ -Dlinux -D__ELF__ -D__unix__ -D__gnu_linux__ -D__linux__ -D__unix -D__linux -Asystem=posix -D__NO_INLINE__ -D__STDC_HOSTED__=1 -Acpu=i386 -Amachine=i386 -Di386 -D__i386 -D__i386__ -D__tune_i386__ hello.c -quiet -dumpbase hello.c -version -o /tmp/cc44nGzf.s GNU CPP version 3.2.3 20030407 (Debian prerelease) (cpplib) (i386 Linux/ELF)
GNU C version 3.2.3 20030407 (Debian prerelease) (i386-linux)
        compiled by GNU C version 3.2.3 20030407 (Debian prerelease).
ignoring nonexistent directory "/usr/i386-linux/include"
#include "..." search starts here:
#include <...> search starts here:
End of search list.
 as -V -Qy -o /tmp/ccB0BYnl.o /tmp/cc44nGzf.s
GNU assembler version (i386-linux) using BFD version 20030121 Debian GNU/Linux /usr/lib/gcc-lib/i386-linux/3.2.3/collect2 --eh-frame-hdr -m elf_i386 -dynamic-linker /lib/ld-linux.so.2 /usr/lib/gcc-lib/i386-linux/3.2.3/../../../crt1.o /usr/lib/gcc-lib/i386-linux/3.2.3/../../../crti.o /usr/lib/gcc-lib/i386-linux/3.2.3/crtbegin.o -L/usr/lib/gcc-lib/i386-linux/3.2.3 -L/usr/lib/gcc-lib/i386-linux/3.2.3/../../.. /tmp/ccB0BYnl.o -lgcc -lgcc_eh -lc -lgcc -lgcc_eh /usr/lib/gcc-lib/i386-linux/3.2.3/crtend.o /usr/lib/gcc-lib/i386-linux/3.2.3/../../../crtn.o
collect2: ld terminated with signal 11 [Segmentation fault]

Initially gcc-2.95 worked, but when I tried to fiddle a bit by removing gcc-2.95 and then put it back it also started to crash.

Some information about my system:
jonas@akka:/usr/local/src/mozilla$ uname -a
Linux akka 2.4.18 #3 lör mar 22 13:37:08 CET 2003 i686 unknown unknown GNU/Linux
I have a 800 MHz Athlon Slot-A processor.

ii  gcc-3.2                   3.2.3-0pre8               The GNU C compiler
ii gcc-3.2-base 3.2.3-0pre8 The GNU Compiler Collection (base package) ii libgcc1 3.2.3-0pre8 GCC support library ii binutils The GNU assembler, linker and binary utilities. ii libstdc++5 3.2.3-0pre8 The GNU Standard C++ Library v3 ii libc6 2.3.1-16 GNU C Library: Shared libraries and Timezone data
BTW, It was about 3 years ago I installed Debian on this computer.

Anyone with a hint of what can be wrong with my system?

/Jonas U

Reply to: