[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Networking - dhcp-client

I have two PCs. One (avocet) is dual boot with win98 and Mandrake 9.0 and the 
other (teal) is dual boot with win95 and debian potato. I have set-up a 
server / router / firewall running Smoothwall which is connected to the 
outside world via cable and a 9 port hub for the home network. In windows 
mode the network works fine but in linux mode only avocet is configured. I 
can reach the outside world and ping smoothwall (and use the remote web 
interface) no probs. Now the problem:

I installed dhchcd on teal but had no luck in obtaining a network connection. 
I then learnt about etherconf and went about downloading all of the files 
(using the windows side and transferring off line) and used dpkg to load all 
the files needed. This involved having to remove dhcpcd an install 
dhcp-client which is the utility used by etherconf. Etherconf runs fine and 
appears set set everything up after a few simple questions. However, the 
truth is dhclient times out after 60 seconds and cannot negotiate a lease.

I have examined the /var/log/syslog with tail on teal in an attempt to 
determine why I STILL can't get a network connection. The log says:

dhclient-2.2.x: DHCPDISCOVER on eth0 to port 67 interval 7
dhclient-2.2.x: 5 bad IP checksums seen in 5 packets
dhclient-2.2.x: no DHCPOFFERS received.
dhclient-2.2.x: no working leases in persistent database
dhclient-2.2.x: Sleeping

If I run dhclient my smoohtwall server drive light flashes as do the lights on 
the hub. There is clearly an attemp being made but on every occassion the 
attempt ends after 60 seconds (the time out) to no avail.

There is a /etc/dhclient.conf which is a sample config file that is commented 
out and it says that it is optional. I have tried editing this also (as well 
as running blank) but it makes no difference.

Does anyone have any experience with this package / script. I previously tried 
using the dchpcd but had to remove this to try out etherconf. I am beginning 
to think that there is something fundamently wrong with my setup, but what I 
don't know?

I am very impressed with debian and am desperate to give it a broadband 
connection so that I can really start using it.

		Alan Lakin
	Wallington, Surrey, England

Reply to: