[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: gnome 2.2 post-install: icon theme doesn't load, theme-manager segfaults

Hi.  Thanks for the quick reply.

On 01 Apr 2003 23:39:34 -0500
James D Strandboge <jstrand1@rochester.rr.com> wrote:
> On Tue, 2003-04-01 at 20:35, Chris Metzler wrote:
>> When this occurred, I decided to try and fix it manually by setting
>> the icon theme through gnome-theme-manager . . .which brings up the
>> second problem.  However I try to start it, gnome-theme-manager
>> immediately segfaults. I have an strace if anyone's interested (it's
>> long, so not posting it here).
> I can't speak to your whole post, but gnome-theme-manager crashes with
> an older gnome-vfs (can't remember the exact version off hand, but its
> been fixed for a while).  Do you have the latest gnome-vfs from
> unstable?

Hi.  Thanks for the quick reply.  Yeah, the vfs packages (libs, extras,
etc.) are all the current versions in sid.

I did some reading at gnome's bugzilla for similar bugs and noted that
some people who filed similar bugs claimed to be missing a particular
key in their .gconf database, one for the icon theme (see e.g.
http://bugzilla.gnome.org/show_bug.cgi?id=104676 ).  I created that
entry with the gconf-editor and I'm now getting icons; what's more,
gnome-theme-manager doesn't crash.  This makes some sense in that
the strace looks like it segfaults right after a read of a null string
(I'm just learning C and barely understand this).  So I *think* my
problem is solved.  This leaves the question of why the initial .gconf
entries aren't being set properly -- and why it's only *some* people
that have this problem -- but anyway . . .

Thanks much,


Chris Metzler			cmetzler@speakeasy.snip-me.net
		(remove "snip-me." to email)

"As a child I understood how to give; I have forgotten this grace since I
have become civilized." - Chief Luther Standing Bear

Reply to: