[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Phoenix with java ..




On Sun, Mar 16, 2003 at 03:29:29PM -0500, Kevin Coyner wrote......
 
> > > 1) install phoenix(I install to ~/phoenix)
> > > 2) download java:
> > > http://java.sun.com/j2se/1.4.1/download.html
> > > (I downloaded the linux self extracting file)
> > > 3) chmod +x the java file and run it, move the directory to /usr/local/java
> > > 4) exit phoenix
> > > 5) cd ~/phoenix/plugins
> > > 6) ln -s /usr/local/java/plugin/i386/ns610/libjavaplugin_oji.so
> > > 7) start phoenix
> > > 8) in url box type about:plugins to be sure it's loaded
> > > 9) test it by going to:
> > > http://java.sun.com/openstudio/applets/clock.html
> 
> I did this last month on a testing box and as I stated, it worked great.
> I tried it today on an unstable box, and it doesn't work.  I get this
> err msg back when trying to start galeon from a console:
> 
> LoadPlugin: failed to initialize shared library
> /usr/local/java/plugin/i386/ns610/libjavaplugin_oji.so
> [/usr/local/java/plugin/i386/ns610/libjavaplugin_oji.so: undefined
> symbol: GetGlobalServiceManager__16nsServiceManagerPP17nsIServiceManager]
> 
> Has anyone been down this path before?  Would appreciate any tips.

Should have done a bit more research before my posting the question as
I've got it figured out now.  So apologies for the one-sided discussion
here.

I essentially did steps #1-9 above, except instead of getting the Java
plugin from Sun I got it from Blackdown at:

ftp://ftp.mirror.ac.uk/sites/ftp.blackdown.org/java-linux/
JDK-1.4.1/i386/01/j2re-1.4.1-01-linux-i586-gcc3.2.bin

The link came from another posting about this same problem that was
posted earlier.

Got it working with this download from Blackdown.  I guess there's a
problem with compiling the Sun version with gcc3.2, which is the default
compiler for unstable (if I've understood everything correctly).

Kevin

-- 
Kevin Coyner
mailto: kevin@rustybear.com
GnuPG key: 1024D/8CE11941

Attachment: pgpzYPYA1ni8x.pgp
Description: PGP signature


Reply to: