[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Phoenix with java ..




On Thu, Feb 27, 2003 at 09:09:55PM -0800, nate wrote......

> I guess I deleted the mail from I think "Sandip" but I decided
> to try to get java working in phoenix 0.5 and it seems to work..
> 
> what I did:
> 
> 1) install phoenix(I install to ~/phoenix)
> 2) download java:
> http://java.sun.com/j2se/1.4.1/download.html
> (I downloaded the linux self extracting file)
> 3) chmod +x the java file and run it, move the directory to /usr/local/java
> 4) exit phoenix
> 5) cd ~/phoenix/plugins
> 6) ln -s /usr/local/java/plugin/i386/ns610/libjavaplugin_oji.so
> 7) start phoenix
> 8) in url box type about:plugins to be sure it's loaded
> 9) test it by going to:
> http://java.sun.com/openstudio/applets/clock.html
> 
> worked for me ....

I didn't have Java installed, but saw this thread and this post (thanks
nate) that made it look so easy, so I gave it a try.

It worked for me (both galeon and phoenix), but I had to do one more
thing in order for it to work.  My system did not have the package

libstdc++2.9-glibc2.1

I noticed that I needed this when I started up galeon from a console.
It gave a message that it was trying to load the java plugin but failed
because the plugin couldn't find the file

[libstdc++-libc6.1-1.so.2: cannot open shared object file: No such file
or directory]

So I went to http://packages.debian.org and searched for packages
containing libstdc++-libc6.1-1.so.2.  It returned the package name for
me, I installed it, and presto - java works.

HTH.

Kevin

-- 
Kevin Coyner
mailto: kevin@rustybear.com
GnuPG key: 1024D/8CE11941

Attachment: pgp1nvzX5jRVP.pgp
Description: PGP signature


Reply to: