[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Switching to console mode from X problem almost solved

>From someone else who's stuck with a S3 Trio as well - XFree86 4.1
doesn't support an accelerated S3 driver so I'm using XFree 3.3.6.  Am
guessing but maybe you are using XFree 4.1 - getting round the fact the
driver isn't directly supported by using the svga module.  The good news
is XFree 4.2 supports the S3 Trio directly so upgrading to testing might
solve the problems.

On Sun, 2 Mar 2003 13:34:36 -0800
"Sam Yuval" <ssy7@hotmail.com> wrote:
> Several weeks ago I sent an email concerning my inability to switch
> from X windows to the virtual console using Ctrl+Alt+F1. I own a
> Viewsonic P810 21" monitor and an S3 Trio 2D/4X video adapter. It
> appears that the problem is cause the use of the wrong X server: when
> I started using xserver-svga instead of xserver-xfree86, the problem
> disappeared. I hope this is a helpful hint for other users who
> experienced the same problem I did.    There is however, one
> unexplained problem: I have 8 MB of RAM on the adapter (according to
> Windows 98), but Linux-based probing software can only detect 4 Mb.
> Furthermore, when I set up X to use all 8192 Kb of ram on the card
> (using dpkg-reconfigure xserver-svga), my sprite turns into a usually
> white square. When I tell X to use only 4096 Kb of ram, the problem is
> solved, but the card cannot handle high refresh rates. Any ideas?
Do You Yahoo!?
Everything you'll ever need on one web page
from News and Sport to Email and Music Charts

Reply to: