[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: apt-get, KDE, and gnomemeeting

sport woman wrote:

I'm trying to run gnomemeeting(version greater than
0.12) and Debian KDE at the same time, but when I try
to upgrade gnomemeeting (I only find upgrades from
USA/unstable), I get (from apt-get install) a message
saying that in order to do this, it has to get rid of
KDE.  (I'm running the 2.4.18 Linux kernel with
Debian, and my /etc/apt/sources.list started with only
stable but now I have done a 'dist-upgrade' to

I am using the 'apt-get' instructions from
(section 3.8) for a mixed system... so now my
/etc/apt/sources.list has a source for unstable debian
packages. (I need the unstable for gnomemeeting.)  I
had thought that using 'apt-get -t unstable install
gnomemeeting' should pull all necessary packages that
would need to be upgraded (including KDE)...however
instead KDE would be removed, when I try this command.
 If someone could please clarify the problem for me, I
would appreciate it.  (I am not using apt pinning,
instead I am attempting to maintain a mixed system.)

According to the debian bug-fix maintainer for
gnomemeeting, I definitely should be able to use
gnomemeeting 0.96 with KDE 3.1.... I don't want to
bother him anymore with my questions, especially since
he directed that I should ask any further questions of
this email list (and previously, the gnomemeeting
mailing list, actually the gnomemeeting author
himself, had directed me to take my question to Jose

Thank you for any clarification,

If I try to "upgrade" to any GNOME packages in "unstable" for the last few weeks, I get the same thing... it wants to remove my KDE 2.2.2 install completely! I am fairly sure this is due to the transition to the use of the gcc 3.2 compiler in "unstable". Most of the apps in "unstable" are being compiled aginst the newer compiler, and I suspect GNOMEMEETING has been too from the results you are getting. The problem seems to be in a small portion of the new compiler (the C++ portion) that isn't compatable with the 2.95 compiler used in "stable" and "testing" currently.

You have a couple of choices here depending upon your needs.

1. You can wait until the transition to the new compiler is complete and it filters into "testing" as the standard compiler. When this happens, chances are a LOT of apps from "unstable" will flow into "testing", including GNOMEMeeting. My sense is that this will probably take a while... several months before it all settles out.

2. You can d/l the source and compile it against the 2.95 version compiler you have currently installed. Dunno if this will work or not, but is worth a try IF you have an "urgent" need. Be prepared to do some trouble-shooting! Otherwise, you will have to wait for the system to "do its thing".

I guess a third choice would be to upgrade to a SID system completely, but you have to risk the chances of breakage due to the constant state of change. KDE 3.1 is starting to flow into SID (unstable) but isn't completely there yet. I have been waiting to see a few more packages appear before I make the leap from KDE 2.2.2 to KDE 3.1.

These are perilous times... <grin>


-Don Spoon-

Reply to: