[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Chinese input [100% SOLVED!]

On Fri, 28 Feb 2003 22:24:23 +0800
Arne Goetje <20020531antispam@gmx.net> wrote:
> Attached is my xcinrc (/etc/), it has root-over-the-spot only by default.

Dear Arne,

Hi, after this post, we should probably take this discussion off-list because maybe the general Debian users might not be interested. If you're not using your real Email address on this list, please contact me.

The problem is 100% solved, and I couldn't have done it without your help! The sample /etc/xcinrc provided me with the final clue, though I was not able to simply substitute your file for mine (indeed, that broke xcinterm-big5 as well). The problem was indeed with the /etc/xcinrc file, and I had to edit it by hand to fix it.

Running xcinterm-gb from an xterm, I was getting (along with the standard output) this error message:

   xcin: error: /etc/xcinrc:
           IM section "array30": SETKEY: value not specified.

After examining my /etc/xcinrc file and comparing it to yours, I noticed many differences, but the line that seemed relevant was this:

    (define array30@gbk

I changed this to read:

   (define array30@gb2312

That's all. Everything worked fine after that.

So all is well, except that I think I should file a bug report. This really seems like a bug to me, because I didn't do anything other than "apt-get install xcin" - I made no attempt to tweak the default settings. I'm not sure if this bug report should go to Debian or Xcin. Can you suggest where I should file it?

My packages came from Debian stable 3.0r1, if that gives any clues.

thank you again for all your help,
Robert Storey (in Taiwan)

Reply to: