[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Disk Corruption

On Tue, Feb 04, 2003 at 06:30:05PM -0500, Jonathan Brandmeyer wrote:

> /boot/boot-menu.b: no such file or directory.   Hmm... 
> > 
> > +++++++++++++++++
> > I have other things under that, and when I boot, I get a red menu with the
> > list to choose from.  It waits a while and then goes off to load the first
> > one if I don't choose.
> This is what used to happen 

I could be wrong about that being what makes the menu happen.  A quick
glance at 'man lilo.conf' indicated that it was the source of it.  

> > 
> > I'm afraid that I do not know anything about putting LILO in a partition -
> > I've only put it in the mbr of the first drive or on a floppy before.  
> > 
> > I don't understand how LILO could be in /dev/hdb1 and have both hda1 and
> > hdb1 bootable.  I thought that whatever was in /dev/hda1 would then boot. 
> > I would suggest putting LILO in the mbr of the first drive (/dev/hda) except
> > that I don't know if that would wipe out something that is needed in order
> > to boot XP.  I know it would be OK for Win 98, but don't know about XP.
> Actually, I tried that, and LILO refused with the error that it wasn't
> able to be written to that type of partition. (NTFS)
> "Device 0x0301: Partition type 0x07 does not seem suitable for a lilo
> boot sector."

There is a difference between /dev/hda and /dev/hda1.  You tried to put it
in the partition.  I'm talking about the master boot record.  That would be
boot=/dev/hda not boot=/dev/hda1

> > To me it looks like LILO was somewhere and got removed and that which is on
> > /dev/hdb1 was never really what was being used.  That sounds kind of off the
> > wall, but I'm not an expert on LILO either.  You have written the same thing
> > that is written on /dev/hdb1 onto the floppy and that works (no menu, but no
> > 01's either) so that means that some other place on your drives is getting
> > accessed during the boot - something other then the boot sector on /dev/hdb1
> > unless maybe that boot sector is shot for some reason.  That doesn't sound
> > good and I don't even know if that is possible.  
> I am starting to think the same thing.  Lilo is writing to the boot 
> sector for /dev/hdb, so I would expect it to preform some basic sanity 
> checks when it does so.  That leaves /dev/hda as the culprit.

Same as above.  You are writing LILO to the boot sector of the first
partition not to the master boot record of the second drive.  I don't know
what would happen if you used /dev/hdb instead of /dev/hdb1. 

> Added 'prompt' on its own line, and raised delay to 100
> I just re-ran liloconfig, once for fd0 and once for hdb1.  Booting from
> HDD did not work.  Booting from the floppy caused this error:
> Lilo: descriptor checksum failed
> and then stopped without a prompt.  I removed the 'prompt' directive,
> left the delay at 100, and re-ran LILO again for both drives.  Now I can
> hit a key to get the menu and boot into either WinXP or Linux.  I booted
> into XP and ran scandisk on dixk C:\ (hda), which found no errors.
> -Jonathan

So now you get the red menu when you hit any key using the floppy?  Well, I
don't know anything more to tell you.  I'm surprised someone more in the
know hasn't chimed in already.  LOL.  At this point I don't know what to
recommend.  I don't know where /boot/boot-menu.b comes from.  I did 'dpkg
-S' on the file and it says it's part of the lilo package.  It's about 7Kb
in size.   


Reply to: