[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: hard crash despite UPS

I am seeing something similar (but no LSR safety check message)
sometimes on my SuSE 7.1 system.  Sometimes it does a system shutdown
5 seconds after the power fail.  Other times it works fine.

I had been attributing it to my abusing the UPS by holding the off
switch down to keep the TV powered up so I could watch a tornado pass
nearby.  I was about to replace the gel cell.  Before doing so, I
tried disabling the shutdown script.  It ran for 20 minutes and then
the UPS shut itself off.

Also I switched from a 450MHz PIII to a Athlon XP 1800+ and from a 17"
CRT to a 17" LCD.  Who knows what the difference that makes a
difference really is.


Quoting Ross Boylan <RossBoylan@stanfordalumni.org>:
> My UPS, an APC BackUPS 650, seems ineffective under Linux.  Originally
> I thought this was because it could not cope with the load, but it
> works OK under MS-Windows.
> That is, when I pull the cord from the wall under Windows I get an
> alert the UPS is on battery.  When I do the same under Linux, the
> system powers off immediately (not a controlled shutdown).
> I use the apcupsd on a woody system with 2.4.19 kernel.  Suspecting a
> configuration problem, I reviewed my settings with APC tech support,
> but this didn't help.  I also tried disabling the demon before pulling
> the plug; this didn't help.  I think this kills the theory that it is
> a problem with apcupsd.
> I do notice that I get the error message
> LSR safety check engaged
> on ttyS1 whenever I run the apcupsd demon (as well as on system start
> up).  I see in the newsgroups this is a sign that something is wrong
> with the serial driver, but I'm not sure what. ttyS1 is where the UPS
> communicates.
> Hmm, I suppose a further test would be to disconnect the serial cable
> and see if this makes a difference.
> Anyway, I'm at a bit of a loss to track this problem down, and would
> appreciate any assistance.  Some theories, none compelling, that occur
> to me: 
> 1) Something else is watching ttyS1 and causing the shutdown.  (What?)
> 2) The UPS detects that communication has failed and shuts down.  The
> problem with this theory is that the UPS uses simple (dumb) signalling:
> messages only go from the UPS to the computer. So there doesn't seem
> to be anyway the UPS would even know there was a problem.
> 3) The system draws more power under Linux than Windows 2000, and this
> is just enough to put the battery over the edge.  This assumes
> something else is weakening the battery, because it nominally clearly
> has enough juice.  However, my utility power is pretty poor, and this
> could strain the system.
> 4) apcupsd is still hanging around despite /etc/init.d/apcupsd stop,
> and it's still the culprit. (I can try removing the package).
> Some possibly relevant log entries (gaps indicate omissions):
> Jan 22 14:25:48 wheat kernel: Serial driver version 5.05c (2001-07-08) with MANY_PORTS SHARE_IRQ SERIAL_PCI ISAPNP enabled
> Jan 22 14:25:48 wheat kernel: ttyS00 at 0x03f8 (irq = 4) is a 16550A
> Jan 22 14:25:48 wheat kernel: ttyS02 at 0x03e8 (irq = 4) is a 16550A
> Jan 22 14:25:48 wheat kernel: ttyS01 at port 0x02f8 (irq = 3) is a 16550A
> Jan 22 14:25:48 wheat kernel: eth0: Setting 100mbps full-duplex based on auto-negotiated partner ability 41e1.
> Jan 22 14:25:48 wheat kernel: ttyS1: LSR safety check engaged!
> Jan 22 14:25:48 wheat last message repeated 2 times
> Jan 22 14:25:49 wheat kernel: ttyS1: LSR safety check engaged!
> Jan 22 14:25:49 wheat apcupsd[396]: apcupsd 3.8.5 (4 January 2002)
> debian startup succeeded
> There are no log entries from the time of the crash.
> genpower was on my system, but I removed it.
> acpid is installed

Reply to: