[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Emacs installed, why?



On Wed, 15 Jan 2003 11:15:22 -0700
bob@proulx.com (Bob Proulx) wrote:
> It does seem strange that there is no line saying, "The following
> packages will be upgraded".  Was that just missed in the cut-n-paste?
> But it is important information.

    Yes, I stopped the cut and paste that the important part of emacs20 being
in the "following NEW packages" to be installed.

> On first pass it would seem that almost any upgrade in unstable would
> want to upgrage at least one package and therefore it must just be
> missing from your post.  I would look over that list of packages and
> see which of them is pulling in emacs20 and pushing out gnupg and
> other such dependencies.

    Well I know that sylpheed-claws is being dropped because of something to
do with gpg which is being dropped because gpg-idea is being dropped.  That
one I've followed and I can get around that.  The constant addition of emacs20
though is getting on my nerves.  :/

    Here's the whole list:

root@teleute:~# apt-get dist-upgrade -u
Reading Package Lists... Done
Building Dependency Tree... Done
Calculating Upgrade... Done
The following packages will be REMOVED:
  gnupg gpg-idea libgpgme6 libgtk-common liblcms libmagick5 libncurses4-dev
  libpango-common sylpheed-claws 
The following NEW packages will be installed:
  emacs20 emacsen-common fontconfig libglu1 liblcms1 libmagick5.5.3
  libssl0.9.7 libwmf0.2-7 
The following packages have been kept back
  aspell-en libgd1 libpspell-dev rwho 
The following packages will be upgraded
  apache-doc autotools-dev bind bind-doc bison bsdutils console-data cpp
  cpp-3.2 debconf-utils debianutils dictionaries-common doc-linux-text
  fileutils g++ g++-3.2 gcc gcc-3.0-base gcc-3.2 gcc-3.2-base gettext-el
  gnome-bin gnome-libs-data groff-base grub imagemagick ipopd libart2
  libatk1.0-0 libc-client2002 libcupsys2 libfontconfig1 libgcc1 libgcrypt1
  libgdk-pixbuf2 libggi2 libglib2.0-0 libgnome32 libgnomesupport0 libgnomeui32
  libgnorba27 libgnorbagtk0 libgtk2.0-0 libgtk2.0-0png3 libgtk2.0-common
  libhdf4g libhdf5-serial libkrb53 libltdl3 libmimelib1 libmm12 libmng1
  libncurses4 libpango1.0-0 libpango1.0-common libpaper1 libpisock++0
  libpisock8 libpng12-0 libpng3 libqt3 libsnmp4.2 libstdc++3 libstdc++5
  libstdc++5-dev libxft2 libxml-perl libxml2 libxslt1 licq man-db mesag3+ggi
  mutt ntp-doc ntp-simple ntpdate openssl palo pan pciutils perl perl-base
  perl-doc perl-modules php4-mysql php4-pear procps python-examples
  python2.2-examples sed shorewall strace tightvncserver traceroute util-linux
  util-linux-locales uw-imapd xfonts-intl-european xtightvncviewer 
99 packages upgraded, 8 newly installed, 9 to remove and 4  not upgraded.
Need to get 66.4MB/66.5MB of archives. After unpacking 33.1MB will be used.
Do you want to continue? [Y/n] n

    I really can't see anything in there that would require emacs.

-- 
         Steve C. Lamb         | I'm your priest, I'm your shrink, I'm your
         ICQ: 5107343          | main connection to the switchboard of souls.
    To email: Don't despair!   |  -- Lenny Nero, Strange Days
-------------------------------+---------------------------------------------

Attachment: pgpBghHIC2I1L.pgp
Description: PGP signature


Reply to: