[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Does a Maxtor 5000 LE USB Drive Work under Linux?

	I want to thank all those who have offered suggestions.
I have a classic good news/bad news progress report.  The good
news is that the drive will work under Linux.  It appears to come
with a Windows file system, but fdisk and mkfs took care of that.

	My problem was that I ended up having no interface
driver.  I had mis understood some of the documentation that
describe use of UHCI and OHCI drivers.  I thought that the USB
support was all you usually needed along with the mass-storage

	It turns out that on my machine, you need the alternate
driver called UHCI.  This produces huge output in the syslog when
it finds the drive and it even reports that it is a Maxtor 500

	I was extatic and really whooped it up when that

	Then the bad news started happening.  The drive works,
but I have something seriously wrong somewhere.

	Firstly, I have tried both the UHCI and OHci drivers to
see which one is the best fit.  The OHCI driver didn't produce so
much as a single syslog message and there was no connectivity.

	The UHCI driver finds the hard drive, but then things get

	I seem to be able to mkfs pretty well if I use /dev/sda1.
I cam copy small files in to and out of it perfectly.  If I copy
a big file such as a 50-meg audio file which is why I installed
it in the first place, I can sometimes get about 32 megs copied
before 1 of 2 things happen.  The fsck or large file copy falls
silent.  Opening another login session and running a ps shows the
original process plus a child spawned by fsck which usually shows
up as having a code of  d  that sometimes changes to  r  and then
back to  d.  As time passes, it is much more  d  than  r and you
can't kill it with an atomic bomb.  Kill -9 does nothing to it
and if you finally give up and are lucky enough to have an open
session to root, reboot starts and then hangs because it can't
even kill that process.

	The only thing that will kill it is literally turning off
the power to the system or, of course, hitting the Reset button.

	Then, you must do fsck on root to get back to a working

	I don't see any syslog errors, but I just know this is
some kind of resource depletion problem.  The drive is working
but my computer which has been rock solid up to now is almost
guaranteed to need a shut-down or hardware reset to bring it back
to life after a large file copy or fsck.

	I am actually about to move everything to a faster system
with twice the memory of the present system, so I don't know if
the problem will follow, but it would be nice to know if anybody
has any theories as to what I might look at.

	I have 64 megabytes of RAM and a 64-meg swap partition
and the main hard disk ranges from 60 to 80% full so it isn't
running out of room for temp files as far as I can tell.

	The other one of the two bad things that happens is that
you suddenly can'tspawn any new logins or one that is open to
root freezes up and absolutely nothing continues to work. 

	A look at processes when the system is sick but not dead
yet shows the parent and child I mentioned plus the usual
assortment of Linux processes, but nothing particularly odd.

	Thanks for any ideas as to what is happening and how to
fix it.  I am so close to success, but still not there yet.

Martin McCormick WB5AGZ  Stillwater, OK 
OSU Center for Computing and Information Services Network Operations Group

Nicos Gollan writes:
>Hash: SHA1
>You should perhaps consider writing a mail to Maxtor support if you 
>haven't done so already.

Reply to: