[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Wireless Device Setup - Total Frustration - Please Help

I have to be missing something basic

I purchased an Actiontec Wireless USB Adapter. It worked immediately with Windows. It is reported to work with Red Hat.

I downloaded Linux-wlan-ng-0.1.16-pre8.tar.gz to /usr/src, unpacked it and followed the README instructions exactly. The dmesg showed the adapter on usb port 3 with prism2_usb assigned to it but lsmod showed prism2_usb inactive and all attempts to activate it failed. I posted questions on the linux-wlan lists, found Jacek Pliszka's page about Prism2 USB 802.11b devices under Linux ( He says he loves the Actiontec 802.11b card) and followed his instructions, found the hardware address on a label on the bottom of the unit and tried the instruction wlanctl-ng wlan0 dot11req_reset setdefaultmib=true macaddress=00:20:E0:95:72:06. The response? No such device.

I gave up.

I purchased a Linksys WMP11 Wireless PCI card. It worked immediately with Windows. Jason's Web Thingy describes step-by-step how he set this card up with Linux kernel 2.4.28.

I reconfigured linux-wlan-ng for a pci card and again followed the instructions exactly. Result? On bootup or executing /etc/init.d/wlan start I get a message that no device was found so the prism2_pci module is not loaded. Again, cat /proc/pci lists the network card.

For reference:

   I am using Debian 3.0 (Woody) with a 2.4.18 kernel.
I built the kernel in /usr/src/linux with all the relavent networking options I could find. I am using System V and inserted a line 19 0,1,6 2,3,4,5 init.d/wlan in runlevel.conf. I inserted a line alias wlan0 prism2_usb (or prism2_pci) in /etc/modutils/aliases and ran update.modules I edited /etc/network/interfaces adding auto lo wlan0 and, on another line, iface wlan0 inet static followed by address and netmask

Some of these things must be redundant (I get the no device found message 6 times on bootup) and may be conflicting. Still, something - probably elementary and right under my nose - is missing and I can't find it.

Reply to: