[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Running Java program

On Monday 30 December 2002 23:47, Jerome "Lacoste (Frisurf)" wrote:
> On Mon, 2002-12-30 at 21:09, Aryan Ameri wrote:
> > Hi there:
> >
> >
> > I have Sun's j2sdk 1.4.1 runtime enviroment installed in my computer. I
> > followed the installation instructions, and installed java. I have it in
> > my PATH and am using it as a mozilla plugin. Mozilla is able to show
> > webpages which use java applets, so I guess my java installation is
> > functional. However I tried running a java program ( LimeWire), which in
> > it's installation notes, says that I should issue the command "java -jar
> > RunLime.jar" in order to run the application. However when I do so I get
> > an error message telling me that -jar is an illegal option. There is also
> > an alternate way to run the program using -cp option, but doing so also
> > gives me an error message telling me that -cp is illegal. I have run this
> > program before, when I used RedHat 7.3.
> > Any Ideas?
> on the command line do:
> which java
> where java and
> java -version

which java tells me that my java is installed in /usr/bin/java while I 
installed my 1.4.1 JRE in /opt/java.sun.
And java -version tells me that my version of java is 1.1.8 . Apparently, I 
have two versions of java installed on this machine. How can I explicitly 
point bash to use the 1.4.1 one instead of the 1.1.8 one?

> > (PS: Off  topic, but I need limewire because I badly need to download
> > Harry Potter ;-)
> My advice: go to a store and buy yourself the video (if it's HP1 of
> course). Then spend the 4 hours you would have spent trying to get the
> video on P2P network on a consulting job, working for mac donalds, going
> out with your girl friend, whatever please you ..
> in one word: get a life.

well, I was talking about the book, not the video. And as it is impossible to 
find the english version of the book in my country, I have no other choice, 
but to download the PDF version of the book. I won't ever dare download a 
vide with my dialup.

On Monday 30 December 2002 23:49, Stephen Gran wrote:
> apt-get install limewire?

I get "Sorry, but the following packages have unmet dependencies:
  limewire: Depends: j2re1.3 but it is not installable". Tried it on both, 
Sarge and sid repositories.


Reply to: