[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

chrony (was: Speaking of ntp, yes CD-R does mess with the clock!)

On Wed, 25 Dec 2002, Paul Johnson wrote:

> On Tue, Dec 24, 2002 at 06:36:22AM -0800, Bill Moseley wrote:
> > Any idea why it conflicts with ntpdate?  Installing it remvoed ntpdate.
> > ntp didn't conflict with ntpdate.
> Because chrony is a ntpdate replacement as well.  ntpdate, thus,
> conflicts with chrony.

I guess it makes sense that you don't want ntpdate changing things while
chrony is running.

There's two things I'm still confused about (well, with regard to

I don't really understand how chrony maintains the hardware clock.  I know
chrony can deal with a slow or fast rtc, but it seems like a good idea to
update the rtc to the real time every once in a while.

I understand there's the rtcfile config option to store the rtc data and
that gets saved on chrony exit (or writertc command via chronyc).  There's
also the trimrtc chronyc command that will update the hardware clock.  

The info page suggests how to deal with power failures by having the
offline script (in /etc/ppp/ip-down.d, for example) issuse the dump and
writertc to save its data and rtc drift info to disk.  But I'm running a
machine that boots and starts the pppoe connection and the only time it
normally goes offline is by powerfailure.  So this data is not written to

Therefore should chronyc be run from cron every so often and run the dump
and writertc (or trimrtc?) commands?

The second thing that seems a bit odd is that I've got chrony.conf's
"server" directives qualified with the "offline" directive, which causes
chrony to startup in offline mode.  (Also means that if you run
init.d/chrony restart while online you are basically stopping chrony.) The
/etc/ppp/ip-up.d/chrony script issues the online command when the ppp
connection is started.  I have the ppp connection starting at boot
(/etc/ppp/ppp_on_boot is a symlink to ppp_on_bood.dsl).

So the confusing thing is the startup scripts.  /etc/rc2.d/S14ppp runs
before /etc/rc2.d/S83chrony.  For some reason it all works now, but it
looks like it's possible that the ppp connection could come up before the
S83chrony script runs which means that /etc/ppp/ip-up.d/chrony could try
to "online" chrony before chrony is running and listening for commands.

Again, it seems like it works now, but it looks like a potential problem
if the ppp connection comes up fast.  Is this true, or have I missed
something in the ppp setup that makes sure it waits long enough for
startup to complete before bringing up the connection?

Oh, and a final note -- chrony's default is to assume that the rtc is set
to localtime.  I had to add "rtconutc" in the config file, but it seems
like it should get that info from /etc/defaults/rcS on installation.

Bill Moseley moseley@hank.org

Reply to: