[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Promise PDC20265 lockups...Please help

On Sun, 2002-12-22 at 00:55, Bradley Alexander wrote:
> I'm having problems with a Promise controller on my motherboard.
> Everything works fine until I plug a drive into it, which kinda defeats
> the purpose of having it on the motherboard. :)
> In any case, it is 1GHz Athlon-C running Debian/sid. The motherboard is
> an Asus A7V133 with 768MB of RAM. It has a VIA Southbridge controlling
> hda-hdd, and a Promise PDC20265 controlling drives hde-hdh. I have 30GB
> drives on hda (Maxtor), hdc (Maxtor) and hde (Quantum), plus DVD drive
> on hdb and a cd-rw on hdd. 

I have that exact same mobo, and it (including hde) has been running
fine for almost 2 years (although of course not with your exact DASD
config), starting with 2.4.2 on Mandrake 7.2(?) up thru Sarge 2.4.20.

Could it be that the Quantum on hde is causing the problem?  What if
you install another device on that channel, just for grins?

Here's a dump from my current dmesg, in case it helps:

Uniform Multi-Platform E-IDE driver Revision: 6.31
ide: Assuming 33MHz system bus speed for PIO modes; override with
VP_IDE: IDE controller on PCI bus 00 dev 21
VP_IDE: chipset revision 6
VP_IDE: not 100% native mode: will probe irqs later
VP_IDE: VIA vt82c686b (rev 40) IDE UDMA100 controller on pci00:04.1
    ide0: BM-DMA at 0xd800-0xd807, BIOS settings: hda:DMA, hdb:pio
    ide1: BM-DMA at 0xd808-0xd80f, BIOS settings: hdc:DMA, hdd:DMA
PDC20265: IDE controller on PCI bus 00 dev 88
PCI: Found IRQ 10 for device 00:11.0
PDC20265: chipset revision 2
PDC20265: not 100% native mode: will probe irqs later
PDC20265: (U)DMA Burst Bit ENABLED Primary PCI Mode Secondary PCI Mode.
    ide2: BM-DMA at 0x8400-0x8407, BIOS settings: hde:pio, hdf:pio
    ide3: BM-DMA at 0x8408-0x840f, BIOS settings: hdg:pio, hdh:pio
hda: Maxtor 94098U8, ATA DISK drive
hde: Maxtor 5T060H6, ATA DISK drive
ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
ide1 at 0x170-0x177,0x376 on irq 15
ide2 at 0x9800-0x9807,0x9402 on irq 10
hda: 80041248 sectors (40981 MB) w/2048KiB Cache, CHS=4982/255/63,
hde: 120103200 sectors (61493 MB) w/2048KiB Cache, CHS=119150/16/63,

> I rebuilt the machine about 2 months ago, and as yet have had no success
> in getting the drive on the Promise controller to work. This worked on
> this same machine prior to the rebuild using 2.4.19.  
> I have tried it with 2.4.18bf2.4 and 2.4.19. I have recompiled 2.4.19
> several times trying different options. On boot, it gets as far as
> checking the drives and then locks hard:
> ide0 at 0x1f0-0xif7,0x3f6 on irq 14
> ide1 at 0x170-0x177,0x376 on irq 15
> ide2 at 0x9400-0x9407,0x9002 on ifq 10
> hda: 60030432 sectors (30736 MB) w/2048KiB Cache, CHS=3736/255/63
> hdc: 60030432 sectors (30736 MB) w/2048KiB Cache, CHS=59554/16/63
> In theory, it then scan hde, but the system freezes, and has to be cold
> booted. I have verified the kernel configs as well as packages (I built
> from the prior package lists, though there are a few differences due to
> the last rebuild being Jun, 1998). 
> Can anyone help me out on getting this drive running?

| Ron Johnson, Jr.        mailto:ron.l.johnson@cox.net          |
| Jefferson, LA  USA      http://members.cox.net/ron.l.johnson  |
|                                                               |
| "My advice to you is to get married: If you find a good wife, |
| you will be happy; if not, you will become a philosopher."    |
|    Socrates                                                   |

Reply to: