[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Promise PDC20265 lockups...Please help

I'm having problems with a Promise controller on my motherboard.
Everything works fine until I plug a drive into it, which kinda defeats
the purpose of having it on the motherboard. :)

In any case, it is 1GHz Athlon-C running Debian/sid. The motherboard is
an Asus A7V133 with 768MB of RAM. It has a VIA Southbridge controlling
hda-hdd, and a Promise PDC20265 controlling drives hde-hdh. I have 30GB
drives on hda (Maxtor), hdc (Maxtor) and hde (Quantum), plus DVD drive
on hdb and a cd-rw on hdd. 

I rebuilt the machine about 2 months ago, and as yet have had no success
in getting the drive on the Promise controller to work. This worked on
this same machine prior to the rebuild using 2.4.19.  

I have tried it with 2.4.18bf2.4 and 2.4.19. I have recompiled 2.4.19
several times trying different options. On boot, it gets as far as
checking the drives and then locks hard:

ide0 at 0x1f0-0xif7,0x3f6 on irq 14
ide1 at 0x170-0x177,0x376 on irq 15
ide2 at 0x9400-0x9407,0x9002 on ifq 10
hda: 60030432 sectors (30736 MB) w/2048KiB Cache, CHS=3736/255/63
hdc: 60030432 sectors (30736 MB) w/2048KiB Cache, CHS=59554/16/63

In theory, it then scan hde, but the system freezes, and has to be cold
booted. I have verified the kernel configs as well as packages (I built
from the prior package lists, though there are a few differences due to
the last rebuild being Jun, 1998). 

Can anyone help me out on getting this drive running?

Bradley M. Alexander                |
Debian Developer, Security Engineer |   storm [at] tux.org
Key fingerprints:
DSA 0x54434E65: 37F6 BCA6 621D 920C E02E  E3C8 73B2 C019 5443 4E65
RSA 0xC3BCBA91: 3F 0E 26 C1 90 14 AD 0A  C8 9C F0 93 75 A0 01 34
The concept is simply staggering. Pointless, but staggering.

Reply to: