[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

RE: Installing a new kernel...

Title: Message

You were right.  At least, sort of.  When I did ctrl-alt-F1, I just got a blank, black screen.   The same with ctrl-alt-F2 -> ctrl-alt-F6.  But when I did ctrl-alt-F7, up popped the gnome login manager.  I was then able to log in just fine and confirm I was running the new kernel.


So I tried rebooting to see if my problem was permanently cured, but it happened again, exactly the same way.  And even after I had logged in, I was still unable to get to a text console with ctrl-alt-Fx.


Has anyone else ever noticed this problem.  I don’t see why it would be an x86-config4 problem as once I’ve logged in the mouse and key board work fine.






-----Original Message-----
From: Narins, Josh [mailto:josh.narins@lehman.com]
Sent: Monday, December 23, 2002 7:51 AM
To: 'alan brown'; debian-user@lists.debian.org
Subject: RE: Installing a new kernel...


Is there any chance you were in TWM, Tim(Tom's?) Window Manager?


It's just a big blue screen, until you start clicking.


I'm no smart guy on kernel upgrades (I've never tried it via apt, for instance) but that blue color rings a bell.


The other suggestion is correct, type Ctrl-Alt-F1 to get a console to see what is going on.


-----Original Message-----
From: alan brown [mailto:alanbrown@pacbell.net]
Sent: Monday, December 23, 2002 3:26 AM
To: debian-user@lists.debian.org
Subject: Installing a new kernel...

I used apt-get install kernel-image-2.4.18-386 to update my kernel.


I added a line to lilo.conf regarding initrd=/initrd.img (or whatever it was that I was told to do while the new kernel was being installed).  Everything went swimmingly.  When I rebooted my system, I couldn't see any problems with the modules being loaded and the devices being checked.  But, just as I was expecting it to offer me the graphical login screen, the whole screen went blank (not black though, it's cyan or turquoise or a bluey green or...).


I was able to reboot and then use LILO to boot my old kernel so everything is under control, but I'm not sure what I did wrong in the install.  The instructions were pretty straightforward.  /vmlinuz points to the new kernel.  /vmlinuz.old points to the old one.  It was all done for me during the install.  In fact, the only thing I had to do was put the aforementioned line in lilo.conf


Any pointers would be appreciated...



This message is intended only for the personal and confidential use of the designated recipient(s) named above. If you are not the intended recipient of this message you are hereby notified that any review, dissemination, distribution or copying of this message is strictly prohibited. This communication is for information purposes only and should not be regarded as an offer to sell or as a solicitation of an offer to buy any financial product, an official confirmation of any transaction, or as an official statement of Lehman Brothers. Email transmission cannot be guaranteed to be secure or error-free. Therefore, we do not represent that this information is complete or accurate and it should not be relied upon as such. All information is subject to change without notice.

Reply to: