[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Needing an old version of gcc...

When installing oracle9i the installer threw an error before it even got started saying that it couldn’t find a gcc file that it needed, namely libstdc++-libc6.1-1.so.2.  So I looked in my /usr/lib directory and saw that I had files very similar to those files (libstdc++-3-libc6.2-2-2.10.0.so) so I symlinked the missing filename to the one I had.  The oracle installation then worked fine.


However, now I’m trying to run the dbca command (database configuration assistant) and it’s falling over almost immediately with the following error…


SIGSEGV   11*  segmentation violation

            stackbase=0xbffff21c, stackpointer=0xbffff0e4


Full thread dump:

    "Finalizer thread" (TID:0x41191210, sys_thread_t:0x444c0e0c, state:R) prio=1

    "Async Garbage Collector" (TID:0x41191258, sys_thread_t:0x4449fe0c, state:R) prio=1

    "Idle thread" (TID:0x411912a0, sys_thread_t:0x4447ee0c, state:R) prio=0

    "Clock" (TID:0x41191088, sys_thread_t:0x4445de0c, state:CW) prio=12

    "main" (TID:0x411910b0, sys_thread_t:0x8231210, state:R) prio=5 *current thread*


Monitor Cache Dump:

Registered Monitor Dump:

    Thread queue lock: <unowned>

    Name and type hash table lock: <unowned>

    String intern lock: <unowned>

    JNI pinning lock: <unowned>

    JNI global reference lock: <unowned>

    BinClass lock: <unowned>

    Class loading lock: <unowned>

    Java stack lock: <unowned>

    Code rewrite lock: <unowned>

    Heap lock: <unowned>

    Has finalization queue lock: <unowned>

    Finalize me queue lock: <unowned>

    Dynamic loading lock: <unowned>

    Monitor IO lock: <unowned>

    Child death monitor: <unowned>

    Event monitor: <unowned>

    I/O monitor: <unowned>

    Alarm monitor: <unowned>

            Waiting to be notified:

                "Clock" (0x4445de0c)

    Monitor registry: owner "main" (0x8231210, 1 entry)

Thread Alarm Q:

./dbca: line 126: 10352 Aborted                 $JRE_DIR/bin/jre -DORACLE_HOME=$OH -DJDBC_PROTOCOL=thin -mx64m -classpath $CLASSPATH oracle.sysman.assistants.dbca.Dbca $ARGUMENTS



Does anyone have any idea what I’ve done wrong.  This maybe the wrong place to post this question, but I imagine there’re a lot of people out there who’ve installed Oracle on Linux and I believe I’ve done a standard install, so I hope someone else has already seen and solved this problem…



Reply to: