[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

dhclient not working properly after failed network install



Hi,

i've installed and configured several debian boxes but
today it was the first time the network part of the installation failed.
I only installed the base part and first wanted to get the network
up and running. Nothing seemed configured which seems logical
since it failed during installation.
Since my server is in for repairs, i connect directly to the internet
via eth0 which should receive an ip from my isp via dhcp.
Nic is based on realtek 8139 but that should already be in the 
bf2.4 kernel (2.4.18).
Pinging localhost works ok.

This is the list of stuff i've setup:
* configure /etc/network/interfaces
* configure /etc/hosts and add 127.0.0.1 localhost
* configure /etc/resolv.conf
* add proper host name in hostname file
* configured /etc/networks (not really necessary as there isn't one)

When i do a "networking restart" or reboot a sentence like 
this comes up:
"Configuring network interfaces: eth0: Setting half-duplex based on
 auto-negotiation partner ability 0000"

Now, this command takes somewhere between 40 to 60 seconds.
I remember that when i installed my server here at home with a 
similar chipset that this wasn't taking this long. But during installation
of the server the network setup worked.

After the 1 minute delay, i haven't received a ip adres: ifconfig
doesn't show one.
Then i tried to run dhclient-script and it then i saw an ip for eth0 
with ifconfig.
It appears that before i run dhclient-script, there is a valid lease in
/var/lib/dhcp/dhclient.leases but why don't i get a correct ip then?

Do i have to add a link to dhclient to rc2.d? But that shouldn't
be necessary since the system is asking for an ip on bootup or
when restarting the network manually.

Is there a way to redo what happens during the installation of the
network so you don't have to do all steps manually?

Thanks




Reply to: