[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bootable CD w/X-CD-Roast: mkisofs error


After several days of trying to create a bootable Knoppix CD from the downloaded .iso, I think with xcdroast I am finally almost there. All except for this error:

Warning: creating filesystem that does not conform to ISO-9660.
mkisofs 1.15a39 (i686-pc-linux-gnu)
Writing:   Initial Padbock                         Start Block 0
Done with: Initial Padbock                         Block(s)    16
Writing:   Primary Volume Descriptor               Start Block 16
Done with: Primary Volume Descriptor               Block(s)    1
Writing:   Eltorito Volume Descriptor              Start Block 17
mkisofs: Uh oh, I cant find the boot image 'boot.img' !

boot.img is in the same directory as the source Knoppix image, as recommended by the 'Boot options' tab's mouseover hottip message:

-rw-r--r-- 1 kenneth kenneth 733675520 Dec 10 23:26 KNOPPIX_V3.1-10-09-2002b-EN.iso
-rw-r--r--    1 kenneth  kenneth      2048 Dec 11 17:07 boot.cat
-rw-r--r--    1 kenneth  kenneth   1474560 Dec 11 17:05 boot.img

I put it & boot.cat there by mounting the .iso and copying them from the CD with

dd if=/cdrom/KNOPPIX/boot.img of=./boot.img
dd if=/cdrom/KNOPPIX/boot.cat of=./boot.cat

I have logging set to verbose & this is what it reports when I push the 'Master to image file' button on the 'Create session/image' tab:

Wed Dec 11 17:08:06 2002 XCDR 0.98alpha10: Entering create cd
Wed Dec 11 17:08:07 2002 XCDR 0.98alpha10: Entering create: master menu
Wed Dec 11 17:08:09 2002 XCDR 0.98alpha10: Getting size of mkisofs-imageWed Dec 11 17:08:09 2002 XCDR 0.98alpha10: Executing: /usr/lib/xcdroast-0.98/bin/xcdrwrap MKISOFS -gui -v -r -J -jcharset default -l -D -L -print-size -b "boot.img" -c "boot.cat" -V "" -P "" -p "" -abstract "" -biblio "" -copyright "" -graft-points "/=/home/kenneth/temp/KNOPPIX_V3.1-10-09-2002b-EN.iso" Wed Dec 11 17:08:44 2002 XCDR 0.98alpha10: Master image /home/kenneth/temp/xcdroast/track-01.img Wed Dec 11 17:08:44 2002 XCDR 0.98alpha10: Executing: /usr/lib/xcdroast-0.98/bin/xcdrwrap MKISOFS -gui -v -r -J -jcharset default -l -D -L -b "boot.img" -c "boot.cat" -V "" -P "" -p "" -abstract "" -biblio "" -copyright "" -o "/home/kenneth/temp/xcdroast/track-01.img" -graft-points "/=/home/kenneth/temp/KNOPPIX_V3.1-10-09-2002b-EN.iso"

the directory /home/kenneth/temp/xcdroast is where I set it to store its temporary files.

I found this page which indicates 'boot.img' must be on the source filesystem, but the source I'm using is already an .iso so I'm not sure how I can achieve that:


I tried copying boot.img to both / & ~temp/xcdroast
I tried using the one directly off the source .iso mounted as /cdrom

I'm running sid with:
xcdroast 0.98alpha10
mkisofs 1.15a39 (i686-pc-linux-gnu)

Any idea what I'm doing wrong here? Where else should I be putting the 'boot.img'?

Thanks in advance,

Reply to: