[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Need help installing from floppy/ls-120 to Thinkpad R31

Hello to all:

Whenever I boot from a rescue disk created with Potato or Woody, then switch to the root disk, I constantly get an end_request error.

I've tried every configuration I can think of, including:

- Switching disable/enable legacy floppy support in BIOS

- Using the LS-120 drive and external "normal" USB floppy drives

- Custom kernel with no RAMDISK support, but with USB and IDE floppy (for the LS-120) and the new Intel E100 NIC.

- Telling Boot: combinations of  rescue root=/dev/fd1 and the thinkpad option

- Booting with only the USB floppy for both rescue and root and no drive (LS-120 or DVD) in the internal bay

I've successfully installed from CD-ROM, but I want to install from normal 1.4 Meg floppies from the LS-120. When I reformatted (due to other issues) I got kernel crashes twice after per subsequent reinstallation attempts.

Windows XP has worked flawlessly on it, so I know the laptop itself is good.

The custom kernel is based on 2.4.20 since it is the latest stable which also supports the new E100 NIC in this Thinkpad.

It is a Thinkpad R31, model 2656 E5U.

Thanks for any help.


Reply to: