[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Realtek NIC and Modem trouble.



Mike Russell said:

> the bios defaults, trying the options like pio instead of mmio in the
> kernel config. The NIC is a Realtek 8139 and the driver used is 8139too.

you try the normal 8139 driver?

> All the hardware above worked fine for me 6 months ago but not now. Both
> the modem and NIC work fine under Win2k. The motherboard is a Asus CUV4X
> with a VIA Chipset.

what kind of modem? internal? external? if internal what I/O and IRQ
addresses are it using? what I/O and IRQs is the network card using?
have you gone to the bios and told it to 'reset configuration data'?
if the modem is ISA and/or external have you told the bios that those
particular IRQs are ISA and not "plug n pray"? Have you tried moving
the pci card to another slot? What kernel version? Have you tried a
2.2.x kernel? I have used 2 CUV4Xs under 2.2.19 with perfect results,
though I only had an external modem, no realtek nic though it was either
an intel or an eepro. what other hardware is in the system?

I have used several realtek cards under 2.2.x, never tried them with
2.4.x though. perhaps the driver is buggy or something. have you tried
building the kernel with the module statically linked? I run all my
kernels static, no modules(unless something cannot be statically linked
such as nvidia or vmware or something).

my CUV4X with external USR courier worked flawlessly for the time I had
it, well until I got good memory and forced the ram at 100mhz instead of
133. It had a peak uptime of 381 days w/o reboot. Rock solid. 2.2.19
kernel(3 hour power outage ended up killing it).

output of /proc/interrupts and /proc/ioports and setserial for the
port of the modem. perhaps a dmesg output too. I reccomend putting
all this in 1 file and posting it on a web site or ftp site or something
and not posting it to the list since it'd be rather large I think.

nate


nate






Reply to: