[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: xmms not openinng its windows

* Ben Hartshorne (debian_user@green.hartshorne.net) [021127 10:38]:
> I've got a strange problem that I'm having trouble tracking down. 
> The symptom:
> I run xmms (either from the command line or my gnome taskbar) and
> nothing happens.
> I run ps -auwx and i can see 4 or so instances of xmms running.

This is normal; a single instance of xmms shows up many times in the
process list because it uses multiple threads.  bind often does the same
thing.  It's also worth noting (while we're on the subject) that the
size and RSS for each independently-listed "process" is the total for
the whole process, so it's really using ~16K, not 4 times that.

> I notice that the xmms gnome-applet has changed it's face (as it does
> when xmms is running) from a logo to the play, pause, etc. buttons.
> I click on play, and music starts coming out of my headphones.
> I can also run xmms-shell and connect to xmms, manipulate the playlist,
> play, pause, etc.  
> Basically, xmms is running, and all other programs that interact with
> xmms work, but I don't see the windows.

> This happened today, and two days ago, but not yesterday.  Logging out
> and logging back in did not help, nor did restarting enlightenment.  I
> havn't tried rebooting.

That sure is odd.  I wonder what changed.  If it is a windowmanager
thing, as I suspect (i.e. it's trying to place itself somewhere
off-screen) maybe whether or not you see it has to do with the position
of other windows at the time.  Does e have a window list?  Is there a
keyboard shortcut to cycle focus?  To move/resize the focused window?

Could you try it from within a different window manager?

> When I run xmms from the command line, I get the following output:
> libmikmod.so.2: cannot open shared object file: No such file or directory
> libvorbisfile.so.0: cannot open shared object file: No such file or directory
> Neither of these packages seem like they would be needed for xmms.

Xmms is trying to load these plugins.  Any reference to them in your
~/.xmms/config ?  how about 'ldd `whence xmms`' -- aah .. there I go
sneaking zsh-isms in there again ;-)  try 'type -p' in place of whence
bash.  Actually, I notice that mine also says it can't load
libmikmod.so.2 (it does find vorbis on my system), btu runs fine.  So I
wouldn't worry about these at all.

> I tried to get more information by running 'strace xmms' but it spewed 
> endless text to the screen -- I don't know what part of that might be
> useful.

strace is more useful with '-o strace.out'.

good times,
One nation, indivisible, with equality, liberty, and justice for all.

Attachment: pgpGFZED6x1Zt.pgp
Description: PGP signature

Reply to: