[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: parted boot CD - SOLVED again :)

On Tue, 2002-11-05 at 12:27, Stephen Gran wrote:
> This one time, at band camp, Alex Malinovich said:
> > On Mon, 2002-11-04 at 16:33, Stephen Gran wrote:
> > > apt-get install parted?
> > > 
> > > Why can't you just run it in single user mode?
> > 
> > DOH! Well, running it in single worked... with one minor problem... it
> > doesn't appear to support reiserfs! :( Well, I guess that kind of
> > changes the nature of my problem now... Any suggestions on how to resize
> > a reiser partition?
> > 
> > -Alex
> steve:~$ apt-cache show parted
> <snip>
> Version: 1.6.3-3
> <snip>
>  Parted currently supports DOS, Mac, Sun, BSD, GPT, MIPS and
>  PC98 disklabels/partition tables, as well as a 'loop' (raw
>  disk) type which allows use on RAID/LVM. Filesystems which
>  are currently fully supported are ext2, ext3, fat (FAT16
>  and FAT32) ReiserFS (with libreiserfs) and linux-swap.
>  Parted can also detect HFS (Mac OS), JFS, NTFS, UFS (Sun
>  and HP) and XFS filesystems, but cannot create, remove,
>  resize or check these filesystems yet.
>  .
>  Note that ReiserFS support is only enabled if you install
>  the libreiserfs0.3-0 package.
> Which version are you using?

I was, in fact, running 1.6.3-3, but there's an outstanding bug against
it (#163107) about this issue. Parted looks for libreiserfs.so
explicitly. Creating a symlink doesn't solve the issue however. I ended
up downloading the source tarballs for parted and libreiserfs
(progrsreiserfs) and building from those and everything went fine. I had
thought that installing progsreiserfs would be sufficient, but that only
resizes the fs, not the partition. All's better now. Hopefully this will
come in handy to someone in the future. (Or, hopefully, the 163107 will
get fixed. :)


Attachment: signature.asc
Description: This is a digitally signed message part

Reply to: