[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Force dpkg to install newer package


I found a problem with the unstable libc6 version and Mozilla (I'll send
another e-mail when this has been solved...). Therefor I've downgraded
libdb1-compat and libc6 and Mozilla worked fine again. Now other programs
won't work anymore, I'll get the following message:

marcel@lemming:/usr/home/marcel$ kmerlin
kmerlin: /lib/libc.so.6: version `GLIBC_2.3' not found (required by

Now I'd like to upgrade libc6 and libdb1-compat back to the unstable
versions (libc6_2.3.1-3 and libdb1-compat_2.1.3-7) however the following
message appears:

lemming:/usr/home/marcel# dpkg -i libc6_2.3.1-3_i386.deb
tar: /lib/libc.so.6: version `GLIBC_2.3' not found (required by tar)
dpkg-deb: subprocess tar returned error exit status 1
dpkg: error processing libc6_2.3.1-3_i386.deb (--install):
 subprocess dpkg-deb --control returned error exit status 2
Errors were encountered while processing:

You'd say you should be able to upgrade back to the appropriate version,
but I can't force dpkg to install these packages. I tried the --force-all
option, but it doesn't seem to work.

Any help would be appreciated.

With kind regards,

Marcel Lemmen
Support Net - Partner in Internetworking

--= Try http://alt.binaries.nl =--

Reply to: