[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

libc6 problems

I fear I've done something very wrong here. I'm trying to stay up to date,
so I run apt-get update; apt-get upgrade on a regular basis.

This time I paid attention; quite a vew packages were held back, so I
tried to install them. I found that libc6 was old:

ii  libc6          2.2.4-5        GNU C Library: Shared libraries and

I tried to upgrade, and got:
The following packages have been kept back
  libc6 libc6-dev locales 
perrin:/tmp# apt-get install libc6
Reading Package Lists... Done
Building Dependency Tree... Done
Package libc6 has no available version, but exists in the database.
This typically means that the package was mentioned in a dependency and
never uploaded, has been obsoleted or is not available with the contents
of sources.list
However the following packages replace it:
  nscd libdb2 ldso 
E: Package libc6 has no installation candidate

This seems odd, and belied too by http://packages.debian.org/libc6. Any

Andrew J Perrin - http://www.unc.edu/~aperrin
Assistant Professor of Sociology, U of North Carolina, Chapel Hill
clists@perrin.socsci.unc.edu * andrew_perrin (at) unc.edu

Reply to: